summaryrefslogtreecommitdiff
path: root/dev-java/jdbc-informix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jdbc-informix
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jdbc-informix')
-rw-r--r--dev-java/jdbc-informix/Manifest3
-rw-r--r--dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild61
-rw-r--r--dev-java/jdbc-informix/metadata.xml8
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-java/jdbc-informix/Manifest b/dev-java/jdbc-informix/Manifest
new file mode 100644
index 000000000000..65d3061ae77f
--- /dev/null
+++ b/dev-java/jdbc-informix/Manifest
@@ -0,0 +1,3 @@
+DIST JDBC.3.00.JC3.tar 18447872 BLAKE2B 61951967bf1d9bd21583fd4270ccd5b177613896f4864a0bcbd9ecaf995e8a097238cb0f4b1f9f65f8012344b88bbd5b91440507192f2e2a63a39f0595a28ce9 SHA512 1f5d0848964b6e805ea735745e8af94664b55dcdf8de664d649b0b261eeac5f36ed0a6cff9bbfdd70b3b574c28b988013c97b1c2011fbcb51f21262f8dda0525
+EBUILD jdbc-informix-3.00.3.ebuild 1657 BLAKE2B 0f6bab8a986d17acdd12f6580506dd16bcea0cac5e21cd7d62e083316091ed133ae1f19ef18d56b1bee2caea748bf91e31059eff22a13d5662fa2576185c27ae SHA512 d38636f0e423c13da399a5d4a20c11fb262ae30adbfcdd7a911c2c7b7502f65280bdcde0fd4faff01ab8c05e61e1d3feb20acd540388bda0ae03ee55ce310d22
+MISC metadata.xml 232 BLAKE2B 513679b02247d8e4cb4c874abd785119d9ca62ad24c44969d52a42c3765d0ebf689024512a2c4c48e69688a4ce02a74ae05708b050a720bc73d8d2bf2ceff58d SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893
diff --git a/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild b/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild
new file mode 100644
index 000000000000..6cfbbfbeffee
--- /dev/null
+++ b/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+JAVA_PKG_IUSE="doc examples"
+
+inherit versionator java-pkg-2
+
+MY_PV="$(replace_version_separator 2 .JC)"
+
+At="JDBC.${MY_PV}.tar"
+DESCRIPTION="JDBC Type 4 Drivers for Informix"
+SRC_URI="${At}"
+HOMEPAGE="http://www.ibm.com/software/data/informix/tools/jdbc/"
+DOWNLOADPAGE="http://www14.software.ibm.com/webapp/download/search.jsp?go=y&rs=ifxjdbc"
+KEYWORDS="amd64 x86"
+LICENSE="informix-jdbc"
+SLOT="0"
+DEPEND=">=virtual/jre-1.4"
+RDEPEND=">=virtual/jre-1.4"
+RESTRICT="fetch"
+IUSE=""
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ elog "Due to licensing restrictions, you need to download the distfile manually."
+ elog "Please navigate to ${DOWNLOADPAGE}"
+ elog "Click on the 'Informix JDBC Driver' link, version ${MY_PV}"
+ elog "Sign up with your IBM account (you need to register)."
+ elog "Go through the license agreement and survey."
+ elog "Download ${At} and place it into ${DISTDIR}"
+ elog "And restart the installation."
+}
+
+src_compile() {
+ einfo "Performing silent installation"
+ addpredict /root/vpd.properties
+ java -jar setup.jar -P product.installLocation=. -silent
+ if use examples; then
+ einfo "Cleaning compiled examples"
+ find demo \( -name \*.so -o -name \*.class -o -name \*.dll \) -delete
+ fi
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+
+ # these are to be copied to app server as servlets
+ insinto /usr/share/${PN}/
+ doins -r proxy
+
+ if use doc; then
+ java-pkg_dojavadoc doc/javadoc
+ dodoc doc/release/jdbc4pg.pdf doc/release/sqlj/ifxsqljug.pdf || die
+ dohtml -r doc/release/* || die
+ fi
+
+ use examples && java-pkg_doexamples demo
+}
diff --git a/dev-java/jdbc-informix/metadata.xml b/dev-java/jdbc-informix/metadata.xml
new file mode 100644
index 000000000000..2444066aa02b
--- /dev/null
+++ b/dev-java/jdbc-informix/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+</pkgmetadata>