summaryrefslogtreecommitdiff
path: root/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild')
-rw-r--r--dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild b/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild
new file mode 100644
index 000000000000..0c6cab80492d
--- /dev/null
+++ b/dev-java/jdbc-informix/jdbc-informix-3.00.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+JAVA_PKG_IUSE="doc examples"
+
+inherit versionator java-pkg-2
+
+MY_PV="$(replace_version_separator 2 .JC)"
+
+At="JDBC.${MY_PV}.tar"
+DESCRIPTION="JDBC Type 4 Drivers for Informix"
+SRC_URI="${At}"
+HOMEPAGE="http://www.ibm.com/software/data/informix/tools/jdbc/"
+DOWNLOADPAGE="http://www14.software.ibm.com/webapp/download/search.jsp?go=y&rs=ifxjdbc"
+KEYWORDS="amd64 x86"
+LICENSE="informix-jdbc"
+SLOT="0"
+DEPEND=">=virtual/jre-1.4"
+RDEPEND=">=virtual/jre-1.4"
+RESTRICT="fetch"
+IUSE=""
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ elog "Due to licensing restrictions, you need to download the distfile manually."
+ elog "Please navigate to ${DOWNLOADPAGE}"
+ elog "Click on the 'Informix JDBC Driver' link, version ${MY_PV}"
+ elog "Sign up with your IBM account (you need to register)."
+ elog "Go through the license agreement and survey."
+ elog "Download ${At} and place it into ${DISTDIR}"
+ elog "And restart the installation."
+}
+
+src_compile() {
+ einfo "Performing silent installation"
+ addpredict /root/vpd.properties
+ java -jar setup.jar -P product.installLocation=. -silent
+ if use examples; then
+ einfo "Cleaning compiled examples"
+ find demo \( -name \*.so -o -name \*.class -o -name \*.dll \) -delete
+ fi
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+
+ # these are to be copied to app server as servlets
+ insinto /usr/share/${PN}/
+ doins -r proxy
+
+ if use doc; then
+ java-pkg_dojavadoc doc/javadoc
+ dodoc doc/release/jdbc4pg.pdf doc/release/sqlj/ifxsqljug.pdf || die
+ dohtml -r doc/release/* || die
+ fi
+
+ use examples && java-pkg_doexamples demo
+}