summaryrefslogtreecommitdiff
path: root/dev-java/jcodings/jcodings-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/jcodings/jcodings-1.0.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/jcodings/jcodings-1.0.5.ebuild')
-rw-r--r--dev-java/jcodings/jcodings-1.0.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/jcodings/jcodings-1.0.5.ebuild b/dev-java/jcodings/jcodings-1.0.5.ebuild
new file mode 100644
index 000000000000..3d8343932380
--- /dev/null
+++ b/dev-java/jcodings/jcodings-1.0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Byte-based encoding support library for Java"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://github.com/jruby/${PN}/tarball/${PV} -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+src_unpack() {
+ default
+ mv jruby-${PN}-* ${P} || die
+}
+
+java_prepare() {
+ cp "${FILESDIR}"/maven-build.xml build.xml || die
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/*
+}