summaryrefslogtreecommitdiff
path: root/dev-java/jcip-annotations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jcip-annotations
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jcip-annotations')
-rw-r--r--dev-java/jcip-annotations/Manifest3
-rw-r--r--dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild30
-rw-r--r--dev-java/jcip-annotations/metadata.xml12
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/jcip-annotations/Manifest b/dev-java/jcip-annotations/Manifest
new file mode 100644
index 000000000000..b3a1a34eb99e
--- /dev/null
+++ b/dev-java/jcip-annotations/Manifest
@@ -0,0 +1,3 @@
+DIST jcip-annotations-1.0-1.tar.gz 7524 BLAKE2B cd31ecf1fe1ef4d78a9624cd92b9837acaccc35b1edfe5fbfac517d94edada03b5f7ac065ba21b26b43e6a8a6aef70434f3dfb7a76bb866ef4e3e25467ff1c01 SHA512 22eb285a445b25a718846dad45581dbe7a324a2d670bd05f4b2aa5e850ae34af6bcedbf143e17a7cd6cf7e510e0dd447992ba1d5316432e8a8db5584a1e1973e
+EBUILD jcip-annotations-1.0.1.ebuild 705 BLAKE2B ca622855bb77890a79f336fa709c7e6550f114ed072bb2d3f7eab2c1bb0231c06bdf1cf5ec7a07e527590b2c865ff32b735ad45cd55212b371519b523d518dcb SHA512 9ee18887230329c7149ad8b5d3e81eb57bacb059f7535a9c1ca92c1818edfdf224cd991d8056f1034247a7a717f3373bbe7fae1b973c8c5cc74ce6025e740038
+MISC metadata.xml 583 BLAKE2B c986afba09f7a872552a05f62fc20280ccbbecdc50c2b8ea158d87b160630c643610e431f4ed0202d90c485c40a5947027691639b9b0c8dd90fb1483f2e9c9f2 SHA512 d05c3ee0c0349388f4504ad9b04c17f92659317878215b49f133cc8f9871ccb9cc23625b6d476b88a255c5a452a5c5d82545fb5ef79d8f08b297298d7be92bc4
diff --git a/dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild b/dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild
new file mode 100644
index 000000000000..4eca0bce1671
--- /dev/null
+++ b/dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit versionator java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-$(replace_version_separator $(get_last_version_component_index) -)"
+
+DESCRIPTION="Clean room implementation of the JCIP Annotations"
+HOMEPAGE="https://github.com/stephenc/jcip-annotations"
+SRC_URI="https://github.com/stephenc/${PN}/archive/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${MY_P}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../README.md
+}
diff --git a/dev-java/jcip-annotations/metadata.xml b/dev-java/jcip-annotations/metadata.xml
new file mode 100644
index 000000000000..31c9027a8769
--- /dev/null
+++ b/dev-java/jcip-annotations/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>The JCIP Annotations are really useful, however they are released under the Creative Commons Attribution License, which is not recommended for licensing software and may therefore cause issues for some people.</longdescription>
+ <upstream>
+ <remote-id type="github">stephenc/jcip-annotations</remote-id>
+ </upstream>
+</pkgmetadata>