summaryrefslogtreecommitdiff
path: root/dev-java/jcifs/jcifs-1.3.17-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jcifs/jcifs-1.3.17-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jcifs/jcifs-1.3.17-r2.ebuild')
-rw-r--r--dev-java/jcifs/jcifs-1.3.17-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/jcifs/jcifs-1.3.17-r2.ebuild b/dev-java/jcifs/jcifs-1.3.17-r2.ebuild
new file mode 100644
index 000000000000..5a4129393d4c
--- /dev/null
+++ b/dev-java/jcifs/jcifs-1.3.17-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Library that implements the CIFS/SMB networking protocol in Java"
+SRC_URI="https://jcifs.samba.org/src/${P}.tgz"
+HOMEPAGE="https://jcifs.samba.org/"
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+
+KEYWORDS="amd64 ppc64 x86"
+
+CDEPEND="java-virtuals/servlet-api:3.0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+JAVA_GENTOO_CLASSPATH="servlet-api-3.0"
+
+JAVA_SRC_DIR="src"
+
+DOCS=( README.txt )
+
+S="${WORKDIR}/${P/-/_}"
+
+src_prepare() {
+ default
+ java-pkg_clean
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use examples && java-pkg_doexamples examples
+ einstalldocs
+}