summaryrefslogtreecommitdiff
path: root/dev-java/javatoolkit/javatoolkit-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/javatoolkit/javatoolkit-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/javatoolkit/javatoolkit-9999.ebuild')
-rw-r--r--dev-java/javatoolkit/javatoolkit-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-java/javatoolkit/javatoolkit-9999.ebuild b/dev-java/javatoolkit/javatoolkit-9999.ebuild
new file mode 100644
index 000000000000..60ab2e825142
--- /dev/null
+++ b/dev-java/javatoolkit/javatoolkit-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multilib prefix git-r3
+EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/javatoolkit.git"
+SRC_URI=""
+KEYWORDS=""
+
+DESCRIPTION="Collection of Gentoo-specific tools for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+python_prepare_all() {
+ hprefixify src/py/buildparser src/py/findclass setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --install-scripts="${EPREFIX}"/usr/$(get_libdir)/${PN}/bin
+}