summaryrefslogtreecommitdiff
path: root/dev-java/jackson-annotations/jackson-annotations-2.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-java/jackson-annotations/jackson-annotations-2.13.0.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-java/jackson-annotations/jackson-annotations-2.13.0.ebuild')
-rw-r--r--dev-java/jackson-annotations/jackson-annotations-2.13.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/jackson-annotations/jackson-annotations-2.13.0.ebuild b/dev-java/jackson-annotations/jackson-annotations-2.13.0.ebuild
new file mode 100644
index 000000000000..91338cc24cc9
--- /dev/null
+++ b/dev-java/jackson-annotations/jackson-annotations-2.13.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/FasterXML/jackson-annotations/archive/refs/tags/jackson-annotations-2.13.0.tar.gz --slot 2 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild jackson-annotations-2.13.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.fasterxml.jackson.core:jackson-annotations:2.13.0"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Core annotations used for value types, used by Jackson data binding package."
+HOMEPAGE="https://github.com/FasterXML/jackson-annotations"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( LICENSE README.md release-notes/VERSION-2.x )
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR=( "src/main/java" "src/moditect" )
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_EXCLUDES=(
+ # 1) warning(junit.framework.TestSuite$1)
+ # junit.framework.AssertionFailedError: No tests found in com.fasterxml.jackson.annotation.TestBase
+ com.fasterxml.jackson.annotation.TestBase
+)
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}