summaryrefslogtreecommitdiff
path: root/dev-java/invokebinder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/invokebinder
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/invokebinder')
-rw-r--r--dev-java/invokebinder/Manifest4
-rw-r--r--dev-java/invokebinder/files/invokebinder-1.6-build.xml230
-rw-r--r--dev-java/invokebinder/invokebinder-1.6.ebuild44
-rw-r--r--dev-java/invokebinder/metadata.xml11
4 files changed, 289 insertions, 0 deletions
diff --git a/dev-java/invokebinder/Manifest b/dev-java/invokebinder/Manifest
new file mode 100644
index 000000000000..0c13be1cbf3e
--- /dev/null
+++ b/dev-java/invokebinder/Manifest
@@ -0,0 +1,4 @@
+AUX invokebinder-1.6-build.xml 9883 BLAKE2B 956e962ef531cfc4e3b90aedb804e709c2528c0c37747a4c897686eb5072e01fc95c4fdf5d88c882412da2131751f312b7fbc3a8c90ab9016bcb3b5d2f312480 SHA512 d498da02a99a4dbbf6c05862a027bca3ed06b8575b8cd7f0c1413750b88b48fe6823ee0c02067a6e476f737b8884a1e7e53bcc9dfe7f74613601bd780c3965a2
+DIST invokebinder-1.6.tar.gz 36027 BLAKE2B b1a676063690500ae0a2c39eed7828d115074fd18ac88338e6078413d837f91e5a1a9a5beb2da976f82315fc6fb63de6f3df47e82c2e7589d4689986d78e3fa1 SHA512 cacdd6dd5fe74bbba940be1b3d53b183adc247b74e89cc0784805b2ad2c63d12ca1abe20bacf0a90ea50db7574e43d4ac52b5a46e61912e5153e2ac2f6bc559a
+EBUILD invokebinder-1.6.ebuild 896 BLAKE2B a009c871e0f31e7c7a3cc529348465d9fc60fd120cdfe46668cfe04caa3927d700d297ebccab61c384117cfbbef4a916d036b217d08b0577d6bdc3b9e4409b2c SHA512 0b26690302f1676e171d618a23c9a3d0de1c2bb9b403c3481fcbf6ac604f1f3e948ba4769632e1efbde3479f2a9aebc8eaff9e6f3adc0762fa33be0a87715817
+MISC metadata.xml 331 BLAKE2B 4edea11b1ef0977f1f26276f424639be6a4eeeb104f0e7f962a75e78525d6eac1b2197d7ac14c44c92957f11c63d4217af354b231a0ee88d4dc2507f5d830853 SHA512 f3e69ac0e7eb827f93dc366045471146598db7454a4bf3eab17611189916f2f668f2d24c4ceab1790d0e67a39adabd9b76e669a52ce96110511a051fcea81fd7
diff --git a/dev-java/invokebinder/files/invokebinder-1.6-build.xml b/dev-java/invokebinder/files/invokebinder-1.6-build.xml
new file mode 100644
index 000000000000..55c846cf0427
--- /dev/null
+++ b/dev-java/invokebinder/files/invokebinder-1.6-build.xml
@@ -0,0 +1,230 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 10/12/15 9:24 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="invokebinder-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="invokebinder-1.6"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.7"
+ verbose="false"
+ fork="false"
+ source="1.7">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.7"
+ verbose="false"
+ fork="false"
+ source="1.7">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/invokebinder/invokebinder-1.6.ebuild b/dev-java/invokebinder/invokebinder-1.6.ebuild
new file mode 100644
index 000000000000..6eafa55d1d55
--- /dev/null
+++ b/dev-java/invokebinder/invokebinder-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Provide a friendly DSL for binding method handles"
+HOMEPAGE="https://github.com/headius/invokebinder"
+SRC_URI="https://github.com/headius/${PN}/archive/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+LICENSE="Apache-2.0"
+
+S="${WORKDIR}/${PN}-${P}"
+
+DEPEND=">=virtual/jdk-1.7
+ test? (
+ dev-java/ant-junit:0
+ )"
+RDEPEND=">=virtual/jre-1.7"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_TEST_TARGET="test"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "target/${P}.jar" "${PN}.jar"
+ use source && java-pkg_dosrc src/main/java/com
+ if use doc; then
+ java-pkg_dojavadoc target/site/apidocs
+ dodoc README.markdown
+ fi
+}
diff --git a/dev-java/invokebinder/metadata.xml b/dev-java/invokebinder/metadata.xml
new file mode 100644
index 000000000000..08c499458589
--- /dev/null
+++ b/dev-java/invokebinder/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">headius/invokebinder</remote-id>
+ </upstream>
+</pkgmetadata>