summaryrefslogtreecommitdiff
path: root/dev-java/icedtea-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-java/icedtea-bin
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-java/icedtea-bin')
-rw-r--r--dev-java/icedtea-bin/Manifest1
-rw-r--r--dev-java/icedtea-bin/icedtea-bin-3.16.0-r2.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/dev-java/icedtea-bin/Manifest b/dev-java/icedtea-bin/Manifest
index 872ba7265013..e09e7070c9a6 100644
--- a/dev-java/icedtea-bin/Manifest
+++ b/dev-java/icedtea-bin/Manifest
@@ -13,5 +13,6 @@ DIST icedtea-bin-examples-3.16.0-ppc64.tar.xz 1864968 BLAKE2B e806ccb1d430e42b1a
DIST icedtea-bin-examples-3.16.0-ppc64le.tar.xz 1863432 BLAKE2B fa227b246e5ddb9197c065fa27092b9114ee5423e7d914ceb9dfd3491fb2ddb60707379fb50ece1e8d4834cfe24cc82cb37e341aafc338623c4720bb74f4c4af SHA512 8efa40365c0689e9fdb3d2c350d95a837706219442b46305e3314185afc9cf0dfab51854bddabdf0f6abc50ce9f45b4c3cac66d6d7a4fd472e58f0070507599e
DIST icedtea-bin-examples-3.16.0-x86.tar.xz 1861512 BLAKE2B 3ee3bc1d9bde79aea9e765ad06e29b76617f00077d28ca08042ff23434edbdfa012033bfc5c2e4ca5bf1485b079ce412c399a9ed9ea5df137e627f1d74cadb30 SHA512 df247ee749d9fd41a3bde5c28a8894cff837ff0725c8d45b89134e294d1cba2493de9d7bbab15b6098c464ed11dc317892df87f10f14b507cc3f27e872c92637
DIST icedtea-bin-src-3.16.0.tar.xz 45993284 BLAKE2B 748ce12cf4231af2410523b394f91afffbdb774a73a0754e6df5c124c9c9f8f8cffed82fa84ec5a9940de80127ca9018379f72085b3de1a2ced3146df27aa943 SHA512 546364dcf4a20d7aa6fc68c465f9c77c3a6c24b9b8889629152dc2424b3d9f818d56ea678ecbdcb58e499c1564f246a75d6b9ff00925d9ecc305dec94ba60548
+EBUILD icedtea-bin-3.16.0-r2.ebuild 3537 BLAKE2B f6527a75362dca90b1af003f97e9d2b8c872102ccd1b4ab959205aba79fad467fd53fb885e272da0f2ccb0b0352f84652ffdb21464c6a4465b77ab147ee936cd SHA512 b10c88926f0cadf3c4c33a3d8f6847c00b6235ba635b95dd26fd625c56c04fd7ed5a80091f96fa6f1111448117b90046b3e0985b15ed16117309e3fbde3dbe6d
EBUILD icedtea-bin-3.16.0.ebuild 3362 BLAKE2B c3c098c3d7dfb0ff89cf506fce2ad3b3c0c622aec63186ccd3e27534015e9f08810204909e8c78b3c1a77aae85a085d7bed2f8d7ef48888a39074d95d4f22cbc SHA512 f951ba1b23fe3755a1e53c9a79bb921057e709e333e084dfca1f7f72789a657a24c2d6473e43ca43d6acc83f700e3505551bf2a00020739cb4e6f18b6a31ecad
MISC metadata.xml 476 BLAKE2B 942d8abafaf1f4d2a194142996498e1bf2f50d7c6ff0d230c5164e1316b5919aee4c4e465d04cad7037226d1cfe4883717305f01f6d64e1a0cfc3a439807b235 SHA512 5d426a1cfc24d9bc6a63706bf4daace94dd6b75a31258a114da8f1d0ada743ae1814d1addf287ef3f0fab1540f43f7d1e838440a5819a97fcf56d3928c7ba7d3
diff --git a/dev-java/icedtea-bin/icedtea-bin-3.16.0-r2.ebuild b/dev-java/icedtea-bin/icedtea-bin-3.16.0-r2.ebuild
new file mode 100644
index 000000000000..329f90ac4a8d
--- /dev/null
+++ b/dev-java/icedtea-bin/icedtea-bin-3.16.0-r2.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# pkgcheck reports that multilib-build is not used but in fact it is used
+# from files/icedtea-bin.env.sh so DO NOT REMOVE THAT CLASS even if pkgcheck
+# says it's unused
+inherit java-vm-2 multilib-build toolchain-funcs
+
+abi_uri() {
+ echo "${2-$1}? (
+ ${BASE_URI}/${PN}-core-${PV}${3+-r${3}}-${1}.tar.xz
+ examples? ( ${BASE_URI}/${PN}-examples-${PV}${3+-r${3}}-${1}.tar.xz )
+ )"
+}
+
+BASE_URI="https://dev.gentoo.org/~gyakovlev/distfiles"
+SRC_URI="
+ doc? ( ${BASE_URI}/${PN}-doc-${PV}.tar.xz )
+ source? ( ${BASE_URI}/${PN}-src-${PV}.tar.xz )
+ big-endian? ( $(abi_uri ppc64) )
+ !big-endian? ( $(abi_uri ppc64le ppc64) )
+ $(abi_uri amd64)
+ $(abi_uri arm)
+ $(abi_uri arm64)
+ $(abi_uri x86)
+"
+
+DESCRIPTION="A Gentoo-made binary build of the IcedTea JDK"
+HOMEPAGE="http://icedtea.classpath.org"
+
+LICENSE="GPL-2-with-classpath-exception"
+SLOT="8"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="+alsa big-endian cups doc examples +gtk headless-awt pulseaudio selinux source"
+
+REQUIRED_USE="gtk? ( !headless-awt )"
+
+RESTRICT="preserve-libs strip"
+QA_PREBUILT="opt/.*"
+
+DEPEND="app-arch/xz-utils"
+
+RDEPEND="
+ >=dev-libs/glib-2.60.7:2
+ >=media-libs/fontconfig-2.13:1.0
+ >=media-libs/freetype-2.9.1:2
+ >=media-libs/lcms-2.9:2
+ >=sys-apps/baselayout-java-0.1.0-r1
+ >=sys-libs/zlib-1.2.11-r2
+ virtual/jpeg-compat:62
+ alsa? ( >=media-libs/alsa-lib-1.2 )
+ cups? ( >=net-print/cups-2.0 )
+ gtk? (
+ >=dev-libs/atk-2.32.0
+ >=x11-libs/cairo-1.16.0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.24:2
+ >=x11-libs/pango-1.42
+ )
+ selinux? ( sec-policy/selinux-java )
+ virtual/ttf-fonts
+ !headless-awt? (
+ media-libs/giflib:0/7
+ =media-libs/libpng-1.6*
+ >=x11-libs/libX11-1.6
+ >=x11-libs/libXcomposite-0.4
+ >=x11-libs/libXext-1.3
+ >=x11-libs/libXi-1.7
+ >=x11-libs/libXrender-0.9.10
+ >=x11-libs/libXtst-1.2
+ )
+"
+
+PDEPEND="pulseaudio? ( dev-java/icedtea-sound )"
+
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if [[ "$(tc-is-softfloat)" != "no" ]]; then
+ die "These binaries require a hardfloat system."
+ fi
+}
+
+src_prepare() {
+ default
+
+ # I wouldn't normally use -f below but symlinks in the arm files
+ # make this fail otherwise and any other approach would be tedious.
+
+ if ! use alsa; then
+ rm -fv */jre/lib/*/libjsoundalsa.* || die
+ fi
+
+ if use headless-awt; then
+ rm -fvr */jre/lib/*/lib*{[jx]awt,splashscreen}* \
+ */{,jre/}bin/policytool */bin/appletviewer || die
+ fi
+}
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${ED}/${dest#/}"
+ dodir "${dest}"
+
+ dodoc ${P}-${ABI}/doc/{ASSEMBLY_EXCEPTION,AUTHORS,NEWS,README,THIRD_PARTY_README}
+ use doc && dodoc -r ${P}/doc/html
+
+ # doins doesn't preserve executable bits.
+ cp -pRP ${P}-${ABI}/{bin,include,jre,lib,man} "${ddest}" || die
+
+ if use examples; then
+ cp -pRP ${P}-${ABI}/{demo,sample} "${ddest}" || die
+ fi
+
+ if use source; then
+ cp ${P}/src.zip "${ddest}" || die
+ fi
+
+ # use system-wide cacert store
+ rm "${ddest}"/jre/lib/security/cacerts || die
+ dosym ../../../../../etc/ssl/certs/java/cacerts "${dest}"/jre/lib/security/cacerts
+
+ java-vm_install-env "${FILESDIR}/icedtea-bin.env.sh"
+
+ # Both icedtea itself and the icedtea ebuild set PAX markings but we
+ # disable them for the icedtea-bin build because the line below will
+ # respect end-user settings when icedtea-bin is actually installed.
+ java-vm_set-pax-markings "${ddest}"
+
+ # Each invocation appends to the config.
+ java-vm_revdep-mask "${EPREFIX}${dest}"
+ java-vm_sandbox-predict /proc/self/coredump_filter
+}