summaryrefslogtreecommitdiff
path: root/dev-java/httpcore
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-java/httpcore
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-java/httpcore')
-rw-r--r--dev-java/httpcore/Manifest3
-rw-r--r--dev-java/httpcore/httpcore-4.4.14.ebuild54
-rw-r--r--dev-java/httpcore/metadata.xml7
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-java/httpcore/Manifest b/dev-java/httpcore/Manifest
new file mode 100644
index 000000000000..a5d04bdbc38e
--- /dev/null
+++ b/dev-java/httpcore/Manifest
@@ -0,0 +1,3 @@
+DIST httpcomponents-core-4.4.14-src.tar.gz 591869 BLAKE2B d6f4900d8781cf7189edb2dfa9c1157b02584e8c66cde02dc261b0e29cdfb971e0323ce4478966b8e125df475ab1014fbee5b4bdf411eb118647f47f95c8f1a7 SHA512 9c713c7ea4e966a35ed391bc2a3aa10a0963cd21978c028dbd0790c9c2a6592385c7b2f135ea2836e6c495d9faea1bdcc65aa994bd5548bc2d84db38d5dbb713
+EBUILD httpcore-4.4.14.ebuild 1592 BLAKE2B 692c414be0d6b732716b480552937a1bf7bad992d9c10825a63f0c881b706dbebe880515b0f7e23dbe22ff84b0db5f05884a30a2b55f3a8d2986c86677a2a7eb SHA512 cf8aa04377e6c60954f36e58126cfca7501a921a3e967cf183aa5723481737dc2ab7d9713df0632c0f98134883daf73d59f3e02ac10164c472645ff47d40b456
+MISC metadata.xml 216 BLAKE2B da3631f8f6582ec2aad6497bbadf58b72bd143f39387aa3a5ee5842db7dc470f1693503286c6c1cde6e4f1ac72c271afabd139d1cb6f25de7d06a5469dd66c03 SHA512 241c7b10d088e8d6b9ace6781434e64c4a5d2eb80e5dfceea04e09a9637475e927ebd804588e5624622b24ef60a29331ad07f995360b0c1c2d5ffa25033a9f4d
diff --git a/dev-java/httpcore/httpcore-4.4.14.ebuild b/dev-java/httpcore/httpcore-4.4.14.ebuild
new file mode 100644
index 000000000000..5584b7dab67a
--- /dev/null
+++ b/dev-java/httpcore/httpcore-4.4.14.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom httpcore/pom.xml --download-uri https://mirror.netcologne.de/apache.org//httpcomponents/httpcore/source/httpcomponents-core-4.4.14-src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild httpcomponents-core-4.4.14.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.apache.httpcomponents:httpcore:4.4.14"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache HttpComponents Core (blocking I/O)"
+HOMEPAGE="https://hc.apache.org/httpcomponents-core-ga"
+SRC_URI="mirror://apache/httpcomponents/httpcore/source/httpcomponents-core-${PV}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Compile dependencies
+# POM: httpcore/pom.xml
+# test? commons-logging:commons-logging:1.2 -> >=dev-java/commons-logging-1.2:0
+# test? junit:junit:4.12 -> >=dev-java/junit-4.13.2:4
+# test? org.mockito:mockito-core:1.10.19 -> >=dev-java/mockito-1.9.5:0
+
+DEPEND=">=virtual/jdk-1.8:*
+ test? (
+ dev-java/commons-logging:0
+ dev-java/mockito:0
+ )"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( ../{LICENSE,NOTICE,README,RELEASE_NOTES}.txt )
+
+S="${WORKDIR}/httpcore"
+
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "src/main/java-deprecated"
+)
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="commons-logging,junit-4,mockito"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+src_install() {
+ default
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/httpcore/metadata.xml b/dev-java/httpcore/metadata.xml
new file mode 100644
index 000000000000..0d49beafc75d
--- /dev/null
+++ b/dev-java/httpcore/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>