summaryrefslogtreecommitdiff
path: root/dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild')
-rw-r--r--dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild b/dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..be485169ede2
--- /dev/null
+++ b/dev-java/hoteqn/hoteqn-4.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java applet to view and display LaTeX mathematical equations"
+HOMEPAGE="http://www.atp.ruhr-uni-bochum.de/VCLab/software/HotEqn/HotEqn.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT=0
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ app-arch/unzip
+ >=virtual/jdk-1.6"
+
+JAVA_ENCODING="ISO-8859-1"
+
+S="${WORKDIR}/${P}"
+
+java_prepare() {
+ rm -v mHotEqn.java || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres "${PN}.jar" classes/ -name "*.gif"
+}