summaryrefslogtreecommitdiff
path: root/dev-java/higlayout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/higlayout
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/higlayout')
-rw-r--r--dev-java/higlayout/Manifest5
-rw-r--r--dev-java/higlayout/higlayout-1.0-r2.ebuild41
-rw-r--r--dev-java/higlayout/higlayout-1.0-r3.ebuild37
-rw-r--r--dev-java/higlayout/metadata.xml8
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-java/higlayout/Manifest b/dev-java/higlayout/Manifest
new file mode 100644
index 000000000000..98068978da69
--- /dev/null
+++ b/dev-java/higlayout/Manifest
@@ -0,0 +1,5 @@
+DIST HIGLayout1.0.zip 78855 BLAKE2B 71150d00c8fa01f3820c845abc5fc66b00b9ecb40fec2d70bdd103a39db8857a91b107fc611f486b0d22d6feb9d600841ae02585b20a339a4b6313ac604c7e14 SHA512 13707cee5ba341b8f47bf97525fcecc5ad7d375f5f816f2b2ed6ed38ae398679e39dcf12e4cf135037b46ac94e7ccc17d34ad9c2671b6d4181e3e9cbc50cd58e
+DIST higlayout-1.0.zip 78855 BLAKE2B 71150d00c8fa01f3820c845abc5fc66b00b9ecb40fec2d70bdd103a39db8857a91b107fc611f486b0d22d6feb9d600841ae02585b20a339a4b6313ac604c7e14 SHA512 13707cee5ba341b8f47bf97525fcecc5ad7d375f5f816f2b2ed6ed38ae398679e39dcf12e4cf135037b46ac94e7ccc17d34ad9c2671b6d4181e3e9cbc50cd58e
+EBUILD higlayout-1.0-r2.ebuild 789 BLAKE2B 0b1a134bbb20b7d2d5e5458f826da7e610d601c1d4952746307840d48f4de5e352fa394e62304a9b5af5e4c7a2baa695ea33fd5fc2b54189b052f6dd5c4e457e SHA512 385e04279a658d2a059d4c8574086cb5268e96228073717b8089fa2d644534172ee0c25c1ea0155448c078ef92e834a53e2111d07647f31d310f47de199ba10c
+EBUILD higlayout-1.0-r3.ebuild 751 BLAKE2B 3fce1918ad8cc3b931d285d7de87b76b9234791afa5cec0a384301854660dfadb4fc6bbfca462f5c38c9c515bec3597ba91d7f26c3ad26b2dcda2c632623e200 SHA512 375a1fa95aa2ac538f1c877fc030d805afeee2c5d42f42b6926680cf2dcf732a9560ce5f83aad3c98de28ecbb43f7836c95a00ef8c0eb07b02b3e4e5ffba50be
+MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/higlayout/higlayout-1.0-r2.ebuild b/dev-java/higlayout/higlayout-1.0-r2.ebuild
new file mode 100644
index 000000000000..e42e005e2433
--- /dev/null
+++ b/dev-java/higlayout/higlayout-1.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java Swing layout manager that's powerful and easy to use"
+
+HOMEPAGE="http://www.autel.cz/dmi/tutorial.html"
+SRC_URI="http://www.autel.cz/dmi/HIGLayout${PV}.zip"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}"
+
+java_prepare() {
+ cd tutorial || die
+ for d in *.GIF;
+ do
+ mv $d $(basename $d .GIF).gif || die
+ done
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}
diff --git a/dev-java/higlayout/higlayout-1.0-r3.ebuild b/dev-java/higlayout/higlayout-1.0-r3.ebuild
new file mode 100644
index 000000000000..a94242c71e2d
--- /dev/null
+++ b/dev-java/higlayout/higlayout-1.0-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java Swing layout manager that's powerful and easy to use"
+HOMEPAGE="http://www.autel.cz/dmi/tutorial.html"
+SRC_URI="mirror://gentoo/HIGLayout${PV}.zip -> ${P}.zip"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+DOCS=( Changes.txt readme.txt )
+
+src_prepare() {
+ default
+ cd tutorial || die
+ for d in *.GIF; do
+ mv "${d}" $(basename ${d} .GIF).gif || die
+ done
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use examples && java-pkg_doexamples examples
+ einstalldocs
+}
diff --git a/dev-java/higlayout/metadata.xml b/dev-java/higlayout/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/higlayout/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>