summaryrefslogtreecommitdiff
path: root/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-28 21:05:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-28 21:05:25 +0100
commit9403c20e10161812ed5231e7fd14464ca484aa09 (patch)
treef7757c7c0efe870267d826326a1a44a33ec53125 /dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
parente74494cd71c90a42f7cf78ec655c9c883a26c42a (diff)
gentoo auto-resync : 28:07:2022 - 21:05:25
Diffstat (limited to 'dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild')
-rw-r--r--dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild b/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
new file mode 100644
index 000000000000..13748884cb64
--- /dev/null
+++ b/dev-java/hawtjni-runtime/hawtjni-runtime-1.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID=""
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A JNI code generator based on the generator used by the Eclipse SWT project"
+HOMEPAGE="https://github.com/fusesource/hawtjni"
+SRC_URI="https://github.com/fusesource/hawtjni/archive/hawtjni-project-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( {changelog,notice,readme}.md )
+
+S="${WORKDIR}/hawtjni-hawtjni-project-${PV}"
+
+JAVA_AUTOMATIC_MODULE_NAME="org.fusesource.hawtjni.runtime"
+JAVA_SRC_DIR="${PN}/src/main/java"