summaryrefslogtreecommitdiff
path: root/dev-java/gnu-hylafax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-java/gnu-hylafax
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-java/gnu-hylafax')
-rw-r--r--dev-java/gnu-hylafax/Manifest4
-rw-r--r--dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch70
-rw-r--r--dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r2.ebuild50
-rw-r--r--dev-java/gnu-hylafax/metadata.xml11
4 files changed, 0 insertions, 135 deletions
diff --git a/dev-java/gnu-hylafax/Manifest b/dev-java/gnu-hylafax/Manifest
deleted file mode 100644
index 5d6de0621630..000000000000
--- a/dev-java/gnu-hylafax/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX gnu-hylafax-1.0.3-ClientPool.patch 1940 BLAKE2B 73c2b714938577e0916839b68d29e3a2b2bdff6eb1890af28f5c977889eb6cf4a10efc5e902361a31a05d0f636a23ead43ea9b06a10766475300a212cb39b1f6 SHA512 3c38ad5ea49b7db4870ed5e5e0742499e540481402d685d3d33f3650b33a6f900dc97a6d253fad5b22c1778c080e613b89671a2cf0a2257a9eaef921414e8597
-DIST gnu-hylafax-1.0.3-bin.tar.gz 1742697 BLAKE2B b17facac17157fddfa27c40f58738d51904e2858a5ec80fe36a39038d7301df8d9cd10bbe5fc537d340e9e3c2e69ae590f92ce2fa7e2b004218bc1fd84013624 SHA512 7af66dac5a1b98eddc3d60aa439809f4e683a39a795ca50d0f99f92d4fb17704ab5c7528218be1f4698bca0749efd46c5ec3510e8a10a68b1b77faf1997dc4a2
-EBUILD gnu-hylafax-1.0.3-r2.ebuild 1050 BLAKE2B 0e79c7203e34a4772880f5577ac0021d275116a062b4727f23ab66610e98bd7acbe5665ad3ec60dc69d214f0b9735e28b33b5b50ed151f1770c2b3f29deef729 SHA512 30f77fbb4e5b22fd18992143d01ce5c84239105bd82f5f0c0b0ce7ce9acc8db497a36188d39a6a17ee767daa4183592b145f54e6321baa2b54e62e015b414203
-MISC metadata.xml 318 BLAKE2B af5fe7b92bc4f65e2f669c3531084cdfc21a8151f4f4b76fada93cdbf1d06beb57a5a8ad6e74522a7dbf530afb087b0cabe27885c7d734b75d892d51aa38b146 SHA512 247ef78a724f34f3c9bb26e56f657646e4d0119a242c9e09719ed2af98e09bf49176f72994f738467c8b2d84cdd3adb71d237581ca433e33fe3cc9f1a68a38da
diff --git a/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch b/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch
deleted file mode 100644
index 51bae74646ed..000000000000
--- a/dev-java/gnu-hylafax/files/gnu-hylafax-1.0.3-ClientPool.patch
+++ /dev/null
@@ -1,70 +0,0 @@
---- gnu-hylafax-pool/main/java/gnu/hylafax/pool/ClientPool.java.orig 2015-04-14 18:20:17.113435400 +0000
-+++ gnu-hylafax-pool/main/java/gnu/hylafax/pool/ClientPool.java 2015-04-14 18:20:58.310438791 +0000
-@@ -32,7 +32,7 @@
- import org.apache.commons.logging.Log;
- import org.apache.commons.logging.LogFactory;
-
--import EDU.oswego.cs.dl.util.concurrent.LinkedQueue;
-+import java.util.concurrent.ConcurrentLinkedQueue;
-
- public class ClientPool implements gnu.hylafax.ClientPool {
-
-@@ -42,7 +42,7 @@
-
- private HashMap clientMap;
-
-- private LinkedQueue clients;
-+ private ConcurrentLinkedQueue clients;
-
- private ClientPoolConfiguration configuration;
-
-@@ -66,7 +66,7 @@
-
- public ClientPool(ClientPoolConfiguration configuration) {
- this.configuration = configuration;
-- clients = new LinkedQueue();
-+ clients = new ConcurrentLinkedQueue();
- clientMap = new HashMap();
- workingClients = new HashSet();
- workingClientsToClose = new HashSet();
-@@ -163,8 +163,7 @@
- blocked = true;
- }
-
-- client = (PooledClient) clients.poll(getConfiguration()
-- .getRetryInterval());
-+ client = (PooledClient) clients.poll();
- if (client == null)
- log.warn("No Clients Available.");
- else if (!clientAdded)
-@@ -172,10 +171,10 @@
- }
-
- } else {
-- client = (PooledClient) clients.take();
-+ client = (PooledClient) clients.poll();
- }
- }
-- } catch (InterruptedException e) {
-+ } catch (Exception e) {
- throw new ClientPoolException(
- "Interrupted Thread and No Free Connection Available.");
- }
-@@ -294,7 +293,7 @@
- destroyClient(client);
- addClient();
- } else {
-- clients.put(client);
-+ clients.offer(client);
- size++;
- }
- }
-@@ -306,7 +305,7 @@
-
- log.debug("Released Client.");
-
-- } catch (InterruptedException e) {
-+ } catch (Exception e) {
- log.warn("Was Interrupted.", e);
- destroyClient(client);
- } finally {
diff --git a/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r2.ebuild b/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r2.ebuild
deleted file mode 100644
index 31cf502872d3..000000000000
--- a/dev-java/gnu-hylafax/gnu-hylafax-1.0.3-r2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="source doc"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Java API designed to implement the client protocol portion of the hfaxd server"
-HOMEPAGE="http://gnu-hylafax.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}-bin.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="dev-java/commons-logging:0
- dev-java/commons-cli:1
- dev-java/oracle-javamail:0
- dev-java/java-getopt:1
- dev-java/log4j:0"
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-DEPEND=">=virtual/jdk-1.6
- ${CDEPEND}"
-
-JAVA_GENTOO_CLASSPATH="
- commons-logging
- commons-cli-1
- oracle-javamail
- java-getopt-1
- log4j"
-
-S="${WORKDIR}/${P}"
-
-PATCHES=(
- "${FILESDIR}"/"${P}"-ClientPool.patch #546502
-)
-
-java_prepare() {
- rm -rv "${S}"/lib || die
- find -name "pom.xml" -delete || die
-
- # tarball contains the same sources in gnu-.../sources and gnu-.../main/
- rm -r gnu-hylafax-*/sources || die
-
- epatch "${PATCHES[@]}"
-}
diff --git a/dev-java/gnu-hylafax/metadata.xml b/dev-java/gnu-hylafax/metadata.xml
deleted file mode 100644
index 2ae6e39733cb..000000000000
--- a/dev-java/gnu-hylafax/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">gnu-hylafax</remote-id>
- </upstream>
-</pkgmetadata>