summaryrefslogtreecommitdiff
path: root/dev-java/glassfish-persistence/glassfish-persistence-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-java/glassfish-persistence/glassfish-persistence-1.0-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-java/glassfish-persistence/glassfish-persistence-1.0-r2.ebuild')
-rw-r--r--dev-java/glassfish-persistence/glassfish-persistence-1.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/glassfish-persistence/glassfish-persistence-1.0-r2.ebuild b/dev-java/glassfish-persistence/glassfish-persistence-1.0-r2.ebuild
new file mode 100644
index 000000000000..1117715835eb
--- /dev/null
+++ b/dev-java/glassfish-persistence/glassfish-persistence-1.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Glassfish implementation of persistence API"
+HOMEPAGE="https://javaee.github.io/glassfish/"
+SRC_URI="https://download.java.net/javaee5/fcs_branch/promoted/source/glassfish-9_0-b48-src.zip"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+
+BDEPEND="app-arch/unzip"
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/glassfish"
+
+EANT_BUILD_XML="persistence-api/build.xml"
+EANT_BUILD_TARGET="all"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python2.7-sax-parser.patch
+)
+
+src_prepare() {
+ default
+}
+
+src_install() {
+ cd "${WORKDIR}"/publish/glassfish || die
+ java-pkg_newjar lib/javaee.jar
+
+ insinto /usr/share/${PN}/lib/schemas
+ doins lib/schemas/*.xsd
+}