summaryrefslogtreecommitdiff
path: root/dev-java/freehep-io/freehep-io-2.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/freehep-io/freehep-io-2.2.2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/freehep-io/freehep-io-2.2.2.ebuild')
-rw-r--r--dev-java/freehep-io/freehep-io-2.2.2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-java/freehep-io/freehep-io-2.2.2.ebuild b/dev-java/freehep-io/freehep-io-2.2.2.ebuild
deleted file mode 100644
index 1343d8707ff8..000000000000
--- a/dev-java/freehep-io/freehep-io-2.2.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="High Energy Physics Java library - FreeHEP I/O Library"
-HOMEPAGE="http://java.freehep.org/"
-SRC_URI="https://github.com/freehep/${PN}/archive/${P}.tar.gz"
-LICENSE="Apache-2.0 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND=">=virtual/jdk-1.7
- test? ( dev-java/junit:4 )"
-
-RDEPEND=">=virtual/jre-1.7"
-
-S="${WORKDIR}/${PN}-${P}"
-JAVA_SRC_DIR="src/main/java"
-
-src_test() {
- local DIR=src/test/java
- local CP="${DIR}:${PN}.jar:$(java-pkg_getjars junit-4)"
- local TESTS=$(find ${DIR} -name "*Test.java" ! -name "Abstract*")
- TESTS="${TESTS//src\/test\/java\/}"
- TESTS="${TESTS//.java}"
- TESTS="${TESTS//\//.}"
-
- ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
- ejunit4 -classpath "${CP}" ${TESTS}
-}