summaryrefslogtreecommitdiff
path: root/dev-java/fishbowl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-09 10:40:04 +0100
commitb426a5cef3f0ebe3389686a1c145a834d3a1e120 (patch)
treeeee77f741af6979f620416c573e5203eab81c9c3 /dev-java/fishbowl
parent97b176c73aa78bd33234884388e3978f520161c3 (diff)
gentoo auto-resync : 09:09:2022 - 10:40:04
Diffstat (limited to 'dev-java/fishbowl')
-rw-r--r--dev-java/fishbowl/Manifest3
-rw-r--r--dev-java/fishbowl/fishbowl-1.4.1.ebuild53
-rw-r--r--dev-java/fishbowl/metadata.xml7
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-java/fishbowl/Manifest b/dev-java/fishbowl/Manifest
new file mode 100644
index 000000000000..6316debc5496
--- /dev/null
+++ b/dev-java/fishbowl/Manifest
@@ -0,0 +1,3 @@
+DIST fishbowl-1.4.1.tar.gz 54572 BLAKE2B 75adfbbdf8c2d48ba6ca52d223f87d840e938514183f01bdb6b505a9cfd3485414d32d63f8f1cfc303c3a431c32e1accc9d319003f82b84016a621c8324f70b8 SHA512 9040bc8bad19457a828a88cdbe448ecbb6af6af279db58a4447670cd8a32cacf30d01ea0bc6614f75e3bfd6bf73e0bce06f33014d22e9963fd9e46fbcd2c94c9
+EBUILD fishbowl-1.4.1.ebuild 2031 BLAKE2B 2d12e77d0e476284cbe224de2707dd5520b8e4a1c05f5f94047d7b558496dee81e470fa1a5ecab63c2a8092b037781f37281dcf76b7aee35177572787ee32436 SHA512 8335a6fb0149c0036845826b8468b718cc5e42f7b67a3ccda7930fc170fb296d9e2d93122a942f613d5e5bd405e6fc3b87df789be58e5d082706f41251055026
+MISC metadata.xml 217 BLAKE2B cb41a7bd7e5c55319465d67551eae75371cc72d58629c61f70a7f54c388645d5ab1427c66dfdd5954e36ca40f0d3209f871d476cacd61516dd57e3297aaa601f SHA512 4df8395dcf07c52adadee71ad7dfa9f611ade8485cc9869397d0037272ae9add9b40d90669da8b80e578b4ee14c512da01ba096abe39a5859ac71c5316e425b6
diff --git a/dev-java/fishbowl/fishbowl-1.4.1.ebuild b/dev-java/fishbowl/fishbowl-1.4.1.ebuild
new file mode 100644
index 000000000000..9f5b7717ade0
--- /dev/null
+++ b/dev-java/fishbowl/fishbowl-1.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/stefanbirkner/fishbowl/archive/fishbowl-1.4.1.tar.gz --slot 0 --keywords "~amd64" --ebuild fishbowl-1.4.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.github.stefanbirkner:fishbowl:1.4.1"
+# Tests not possible, several test dependencies are missing.
+# JAVA_TESTING_FRAMEWORKS="testng junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Use the AAA pattern for writing tests for code that throws an exception"
+HOMEPAGE="https://github.com/stefanbirkner/fishbowl/"
+SRC_URI="https://github.com/stefanbirkner/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Compile dependencies
+# POM: pom.xml
+# test? com.google.truth:truth:0.25 -> !!!groupId-not-found!!!
+# test? de.bechte.junit:junit-hierarchicalcontextrunner:4.12.0 -> !!!groupId-not-found!!!
+# test? junit:junit:4.12 -> >=dev-java/junit-4.13.2:4
+# test? org.assertj:assertj-core:1.7.1 -> >=dev-java/assertj-core-2.3.0:2
+# test? org.easytesting:fest-assert:1.4 -> !!!groupId-not-found!!!
+# test? org.hamcrest:hamcrest-core:1.3 -> >=dev-java/hamcrest-core-1.3:1.3
+# test? org.hamcrest:hamcrest-library:1.3 -> >=dev-java/hamcrest-library-1.3:1.3
+# test? org.mockito:mockito-core:1.10.19 -> >=dev-java/mockito-4.4.0:4
+# test? org.testng:testng:6.8.17 -> !!!groupId-not-found!!!
+
+DEPEND=">=virtual/jdk-1.8:*"
+# test? (
+# !!!groupId-not-found!!!
+# >=dev-java/assertj-core-2.3.0:2
+# >=dev-java/hamcrest-core-1.3:1.3
+# >=dev-java/hamcrest-library-1.3:1.3
+# >=dev-java/mockito-4.4.0:4
+# )
+# "
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+# JAVA_TEST_GENTOO_CLASSPATH="!!!groupId-not-found!!!,!!!groupId-not-found!!!,junit-4,assertj-core-2,!!!groupId-not-found!!!,hamcrest-core-1.3,hamcrest-library-1.3,mockito-4,!!!groupId-not-found!!!"
+# JAVA_TEST_SRC_DIR="src/test/java"
diff --git a/dev-java/fishbowl/metadata.xml b/dev-java/fishbowl/metadata.xml
new file mode 100644
index 000000000000..75321cfb5598
--- /dev/null
+++ b/dev-java/fishbowl/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>