summaryrefslogtreecommitdiff
path: root/dev-java/felix-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/felix-shell
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/felix-shell')
-rw-r--r--dev-java/felix-shell/Manifest6
-rw-r--r--dev-java/felix-shell/felix-shell-1.4.3.ebuild44
-rw-r--r--dev-java/felix-shell/files/felix-shell-1.4.3-build.xml299
-rw-r--r--dev-java/felix-shell/metadata.xml8
4 files changed, 357 insertions, 0 deletions
diff --git a/dev-java/felix-shell/Manifest b/dev-java/felix-shell/Manifest
new file mode 100644
index 000000000000..ff9479e10a34
--- /dev/null
+++ b/dev-java/felix-shell/Manifest
@@ -0,0 +1,6 @@
+AUX felix-shell-1.4.3-build.xml 13813 SHA256 484bb6cd4327b550708aa0e1589964ca651d380a611a054c7bd70cff4f894ccd SHA512 324f9a3d1de17756eeff2ed520e3e4639ed371785b3cf422387b75d4dd6790e893d6467308c44b5157a56577a6714c271c6168a9737d7326600f3944fcd4d6be WHIRLPOOL 247021b915ebcadceb8267194dfa10f6c7d40e0be2734c0f6a478fbcf6feec6716cd939ac465fda259b3f7510e7b67683e132e787e01b387ae7dc151328ddf41
+DIST org.apache.felix.shell-1.4.3-source-release.tar.gz 75190 SHA256 daea2ae1cd3e28dbbcf5da964ffa5b6cb37ccc102dc070b878203900e8bf292a SHA512 fe1b3927789a18626715e52a634fa069fdd1505f425a48d76ec6abbb181f511ff5a3af176c70f634241830b185d32cd7eb71a271d62a754366141cd959cb54a4 WHIRLPOOL 6836e3503a26b887997786f2214b32eca527b9b28b98fb9a54179be756fd15f1d41a531ae54bfada956a7a8e66444464b0cd6203b240fb7c283059ae2a90f422
+EBUILD felix-shell-1.4.3.ebuild 1178 SHA256 b173c86c98b0d6974e6ac3df5bea32f4e51d63f915910ad67f2d57d58e3b4b4e SHA512 df389381783d8702f67783b2a1e7c5f9e7a38f540c8377bcc9fecb97b829d78ff864b320b3239352a0472aae711563a468b3cd96779faaf18c8f869713d6e166 WHIRLPOOL 85e78780ff37ddfb43dcf8074af17c5d898c0faf29d6f22bba8acfa8fe083e8aaf36ae8fa531c6d0d7ee12b9e50e7f6653d27b02f1ec072080b43c898889941e
+MISC ChangeLog 2671 SHA256 902457ec8dbe0faefca67a29bcd87fd3b684e39431104667722cc0238aae033a SHA512 ddd2cc015ae0f1a81dc077764b8278a6181f18b83082c551773f93a85f59e385d1fce37c73f23eebd78a8b98d320b4f2f293b65fe545973a4c026650afc800a8 WHIRLPOOL fa9607f88caacfeaba0d0268dab55f5b630e19a36327e01c1054577afb63c71514b40c26d79cc9b477318f7ea93f0d8e5fc7872453a1ad6a5a03fe486c4f22d2
+MISC ChangeLog-2015 639 SHA256 c3eca594ac2381546aa392d4d6bde5c0a26e254bcff61d5978fd42a45611ad05 SHA512 d428c995fc464978693aa9fc02d9d8b788ffbf01e7de4d512e8432e125aa4bf61ee5bcc8f65e5b5f0b015ed1e2acae12991df3a2d3becce2be6aa4f80ea77019 WHIRLPOOL 3ce1d6b6f75180dbe717fecbab48e309e42026606a9d4e11a292d103857f8fb1c1fcf6e2b74ec80958017d5f4f02bdf8bd44dc25d514ca7877091d5727560bad
+MISC metadata.xml 232 SHA256 0c8d91b3d514ac42d0eaca567346ab909c0f947049c85c25a380ec2400f1b3fb SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893 WHIRLPOOL 3a1a6d054edc9177d85ca868f9b0a6e84ee51bab4fbdbb9b1ead1a03874036bcc3f96e903fb751dc4d29fdb7d6b5f3d8dbe7b042fc697c887e23f41cc9c8c4ac
diff --git a/dev-java/felix-shell/felix-shell-1.4.3.ebuild b/dev-java/felix-shell/felix-shell-1.4.3.ebuild
new file mode 100644
index 000000000000..2b1ce8e60499
--- /dev/null
+++ b/dev-java/felix-shell/felix-shell-1.4.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="Felix Shell"
+HOMEPAGE="http://felix.apache.org/"
+LICENSE="Apache-2.0"
+
+MY_PN="org.apache.felix.shell"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://apache/felix/${MY_P}-source-release.tar.gz"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND=">=virtual/jdk-1.6
+ dev-java/felix-gogo-runtime:0
+ dev-java/felix-utils:0
+ dev-java/osgi-compendium:0
+ dev-java/osgi-core-api:0"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_compile() {
+ EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only osgi-core-api osgi-core-api.jar):$(java-pkg_getjar --build-only osgi-compendium osgi-compendium.jar):$(java-pkg_getjar --build-only felix-gogo-runtime felix-gogo-runtime.jar):$(java-pkg_getjar --build-only felix-utils felix-utils.jar)"
+
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ mv "${S}"/target/{${MY_P},${PN}}.jar || die
+
+ java-osgi_dojar "${S}"/target/${PN}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
+}
diff --git a/dev-java/felix-shell/files/felix-shell-1.4.3-build.xml b/dev-java/felix-shell/files/felix-shell-1.4.3-build.xml
new file mode 100644
index 000000000000..6bab51781bd1
--- /dev/null
+++ b/dev-java/felix-shell/files/felix-shell-1.4.3-build.xml
@@ -0,0 +1,299 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/13/13 2:41 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="org.apache.felix.shell-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="org.apache.felix.shell-1.4.3"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.0/junit-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"/>
+ <pathelement location="${maven.repo.local}/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.3"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="changelog.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.3"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0"/>
+ <get src="http://repository.apache.org/snapshots/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"
+ dest="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"
+ dest="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0"/>
+ <get src="http://repository.apache.org/snapshots/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"
+ dest="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"
+ dest="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.0"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.0/junit-4.0.jar"
+ dest="${maven.repo.local}/junit/junit/4.0/junit-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.0/junit-4.0.jar"
+ dest="${maven.repo.local}/junit/junit/4.0/junit-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/easymock/easymock/2.4"/>
+ <get src="http://repository.apache.org/snapshots/org/easymock/easymock/2.4/easymock-2.4.jar"
+ dest="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/easymock/easymock/2.4/easymock-2.4.jar"
+ dest="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/mockito/mockito-all/1.7"/>
+ <get src="http://repository.apache.org/snapshots/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"
+ dest="${maven.repo.local}/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"
+ dest="${maven.repo.local}/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/felix-shell/metadata.xml b/dev-java/felix-shell/metadata.xml
new file mode 100644
index 000000000000..2444066aa02b
--- /dev/null
+++ b/dev-java/felix-shell/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+</pkgmetadata>