summaryrefslogtreecommitdiff
path: root/dev-java/felix-bundlerepository
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/felix-bundlerepository
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/felix-bundlerepository')
-rw-r--r--dev-java/felix-bundlerepository/Manifest4
-rw-r--r--dev-java/felix-bundlerepository/felix-bundlerepository-1.6.6.ebuild50
-rw-r--r--dev-java/felix-bundlerepository/files/felix-bundlerepository-1.6.6-build.xml195
-rw-r--r--dev-java/felix-bundlerepository/metadata.xml8
4 files changed, 257 insertions, 0 deletions
diff --git a/dev-java/felix-bundlerepository/Manifest b/dev-java/felix-bundlerepository/Manifest
new file mode 100644
index 000000000000..202ecb362b0b
--- /dev/null
+++ b/dev-java/felix-bundlerepository/Manifest
@@ -0,0 +1,4 @@
+AUX felix-bundlerepository-1.6.6-build.xml 9293 BLAKE2B 601e91d713369c89b0e511b8dc7deaf077f118c4d3b41cecff3cdc0bcff72655bc13cf0c9f6c68c99f5900efa6cc5bbd83d621a362c469a293f8972b6155d16e SHA512 23b17058603ab1ceac2af7b88d83d112406036cde05350f9f2d750705040ba9d885c54904dab8c29ee8ffdc506e46cff7eab80d19145a80e437f96034b745414
+DIST org.apache.felix.bundlerepository-1.6.6-source-release.tar.gz 163337 BLAKE2B 9eb4a568de9ffac0f744675a5a4c5f84563054931204575fc447af5c33a5cda124b305beb82c45a44a9764a3a26dd985aaf91e5066f68d32fb79c4e60c70a42a SHA512 a457dacf0b15a54aad9290a3620b4dee503bb7d06eac1e2e9b151613caafdd53b104e8266b10321d04d0fb400df6f9f2131ed03f48bf166205903aa69f260b46
+EBUILD felix-bundlerepository-1.6.6.ebuild 1140 BLAKE2B 5a228484e9ad8d0b5dfe5f69d310283fe707d3b236ce2460a143f61bbb26eee7edc936c53bac660b94466ef8060078823a917b023f6cebcf51930e495580387d SHA512 1a88cbcbc814194830fc54a9e2cce61feb1db710b7453c101dad520980ef60b42383a1c801d4acd6614e47acfc2ce1053c3a92dcb9ef348a7a87d65b5093b805
+MISC metadata.xml 232 BLAKE2B 513679b02247d8e4cb4c874abd785119d9ca62ad24c44969d52a42c3765d0ebf689024512a2c4c48e69688a4ce02a74ae05708b050a720bc73d8d2bf2ceff58d SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893
diff --git a/dev-java/felix-bundlerepository/felix-bundlerepository-1.6.6.ebuild b/dev-java/felix-bundlerepository/felix-bundlerepository-1.6.6.ebuild
new file mode 100644
index 000000000000..52bc02a0e8d1
--- /dev/null
+++ b/dev-java/felix-bundlerepository/felix-bundlerepository-1.6.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="Felix Bundle Repository"
+HOMEPAGE="http://felix.apache.org/"
+LICENSE="Apache-2.0"
+
+MY_PN="org.apache.felix.bundlerepository"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://apache/felix/${MY_P}-source-release.tar.gz"
+SLOT="0"
+KEYWORDS="amd64"
+
+CDEPEND="
+ dev-java/kxml:2
+ dev-java/xpp3:0
+ dev-java/felix-shell:0
+ dev-java/felix-utils:0
+ dev-java/osgi-core-api:0
+ dev-java/osgi-obr:0
+"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ sed -i 's/bestVersion.compareTo(v)/bestVersion.compareTo((Version) v)/g' \
+ src/main/java/org/apache/felix/bundlerepository/impl/ResolverImpl.java \
+ || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="osgi-core-api,felix-utils,felix-shell,xpp3,kxml-2,osgi-obr"
+
+src_install() {
+ mv target/{${MY_P},${PN}}.jar || die
+
+ java-osgi_dojar target/${PN}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
+}
diff --git a/dev-java/felix-bundlerepository/files/felix-bundlerepository-1.6.6-build.xml b/dev-java/felix-bundlerepository/files/felix-bundlerepository-1.6.6-build.xml
new file mode 100644
index 000000000000..0c7398178af1
--- /dev/null
+++ b/dev-java/felix-bundlerepository/files/felix-bundlerepository-1.6.6-build.xml
@@ -0,0 +1,195 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project name="org.apache.felix.bundlerepository-from-maven" default="package" basedir=".">
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+ <property name="maven.build.finalName" value="org.apache.felix.bundlerepository-1.6.6"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.apache.felix.utils/1.1.0/org.apache.felix.utils-1.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.osgi.service.obr/1.0.2/org.osgi.service.obr-1.0.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.osgi.core/1.0.1/org.osgi.core-1.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.apache.felix.shell/1.4.1/org.apache.felix.shell-1.4.1.jar"/>
+ <pathelement location="${maven.repo.local}/net/sf/kxml/kxml2/2.3.0/kxml2-2.3.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/codehaus/woodstox/woodstox-core-asl/4.0.7/woodstox-core-asl-4.0.7.jar"/>
+ <pathelement location="${maven.repo.local}/stax/stax-api/1.0.1/stax-api-1.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/codehaus/woodstox/stax2-api/3.0.1/stax2-api-3.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.apache.felix.utils/1.1.0/org.apache.felix.utils-1.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.osgi.service.obr/1.0.2/org.osgi.service.obr-1.0.2.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.osgi.core/1.0.1/org.osgi.core-1.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/apache/felix/org.apache.felix.shell/1.4.1/org.apache.felix.shell-1.4.1.jar"/>
+ <pathelement location="${maven.repo.local}/net/sf/kxml/kxml2/2.3.0/kxml2-2.3.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.compendium/4.0.0/org.osgi.compendium-4.0.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/osgi/org.osgi.core/4.1.0/org.osgi.core-4.1.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/codehaus/woodstox/woodstox-core-asl/4.0.7/woodstox-core-asl-4.0.7.jar"/>
+ <pathelement location="${maven.repo.local}/stax/stax-api/1.0.1/stax-api-1.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/codehaus/woodstox/stax2-api/3.0.1/stax2-api-3.0.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/easymock/easymock/2.4/easymock-2.4.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.0/junit-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/mockito/mockito-all/1.7/mockito-all-1.7.jar"/>
+ </path>
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.3"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="changelog.txt"/>
+ </fileset>
+ </copy>
+ </target>
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.3"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/felix-bundlerepository/metadata.xml b/dev-java/felix-bundlerepository/metadata.xml
new file mode 100644
index 000000000000..2444066aa02b
--- /dev/null
+++ b/dev-java/felix-bundlerepository/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+</pkgmetadata>