summaryrefslogtreecommitdiff
path: root/dev-java/commons-math
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 20:54:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 20:54:05 +0100
commitfc879856a16ea66528a11a00cf6ee19891f3d186 (patch)
tree01ac0b4134970567587e7176ffc531a404898186 /dev-java/commons-math
parentf73bef95b39f4fbc8f0278c26ad1534e5eec322f (diff)
gentoo auto-resync : 24:07:2022 - 20:54:05
Diffstat (limited to 'dev-java/commons-math')
-rw-r--r--dev-java/commons-math/Manifest2
-rw-r--r--dev-java/commons-math/commons-math-3.6.1-r2.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/commons-math/Manifest b/dev-java/commons-math/Manifest
index 006eb3322112..90b1bf9dedad 100644
--- a/dev-java/commons-math/Manifest
+++ b/dev-java/commons-math/Manifest
@@ -1,3 +1,5 @@
+DIST commons-math3-3.6.1-sources.jar 2514690 BLAKE2B ce5dc1a5bdccf85aa780dd648b64c0ed78b4d5a36d15d9737f661135f4f1ec962c3c44a0c4d8fc7d12c667e62b19860cb2a47f507c8c3e6da6cce57e1b9caf54 SHA512 eab6003834c0f1b7e67eee242d33db43f85d388ac32e37caa6bd16d74340db5c189ff5c7fd112ef13b9009d2fbcf2bad6650b6e5d9124316b59493b2d07d065d
DIST commons-math3-3.6.1.jar 2514690 BLAKE2B ce5dc1a5bdccf85aa780dd648b64c0ed78b4d5a36d15d9737f661135f4f1ec962c3c44a0c4d8fc7d12c667e62b19860cb2a47f507c8c3e6da6cce57e1b9caf54 SHA512 eab6003834c0f1b7e67eee242d33db43f85d388ac32e37caa6bd16d74340db5c189ff5c7fd112ef13b9009d2fbcf2bad6650b6e5d9124316b59493b2d07d065d
EBUILD commons-math-3.6.1-r1.ebuild 741 BLAKE2B cddab31becc324b2e4fd262d6de490542cd5f482a1b29dd9a59d8b0139c1e7112545b59349ed9cee2519ddc56d80ee6feba6e65ef5dcb21bb9f1ea3305306f84 SHA512 97a2384bf11b39cea6aab1c041acf2236491d766c799f13342cd4c567b86d4a85cbc1ed500d3c7460bcaacf5565008fc9471af60babb85e3bdfe0f85e0082da7
+EBUILD commons-math-3.6.1-r2.ebuild 774 BLAKE2B 23b4d26fbd92105105b7b590c1fc1080e478b0b31f7b8e61267974e1a5f837f5bdec9fdccba3218f1adc801107ef07482dd7e78ac017fe8edd3f3da9e13476cd SHA512 e06e385c03281343f8e35786d40f3ea79e2f112830d919225588d8b7aeba05eb5b4fdf02eeb766c84c072d3ae766bbb9db7d84e52252ecf9780a33bedf8ab057
MISC metadata.xml 237 BLAKE2B 7c3263833976c18611a5cba44845af4d80f2f86c48cf587a657292ed0074022088cef88756e3209b292252dce5c0eea307c4f2f45f28b8517609124708f7d09a SHA512 e8227b536eb45569cbf744907106e101d1aa6bf9ba8337783786d719ab107d8bda0fde5dd7067d168181d694b4161b12d1ef3cb5a83b14971b21aa4479670559
diff --git a/dev-java/commons-math/commons-math-3.6.1-r2.ebuild b/dev-java/commons-math/commons-math-3.6.1-r2.ebuild
new file mode 100644
index 000000000000..0c33559066fe
--- /dev/null
+++ b/dev-java/commons-math/commons-math-3.6.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc examples source"
+MAVEN_ID="org.apache.commons:commons-math3:3.6.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="https://commons.apache.org/math/"
+SRC_URI="https://repo1.maven.org/maven2/org/apache/commons/${MY_PN}/${PV}/${MY_P}-sources.jar"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+JAVA_AUTOMATIC_MODULE_NAME="commons.math3"