summaryrefslogtreecommitdiff
path: root/dev-java/commons-math/commons-math-3.6.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-24 20:54:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-24 20:54:05 +0100
commitfc879856a16ea66528a11a00cf6ee19891f3d186 (patch)
tree01ac0b4134970567587e7176ffc531a404898186 /dev-java/commons-math/commons-math-3.6.1-r2.ebuild
parentf73bef95b39f4fbc8f0278c26ad1534e5eec322f (diff)
gentoo auto-resync : 24:07:2022 - 20:54:05
Diffstat (limited to 'dev-java/commons-math/commons-math-3.6.1-r2.ebuild')
-rw-r--r--dev-java/commons-math/commons-math-3.6.1-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-java/commons-math/commons-math-3.6.1-r2.ebuild b/dev-java/commons-math/commons-math-3.6.1-r2.ebuild
new file mode 100644
index 000000000000..0c33559066fe
--- /dev/null
+++ b/dev-java/commons-math/commons-math-3.6.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc examples source"
+MAVEN_ID="org.apache.commons:commons-math3:3.6.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="https://commons.apache.org/math/"
+SRC_URI="https://repo1.maven.org/maven2/org/apache/commons/${MY_PN}/${PV}/${MY_P}-sources.jar"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+JAVA_AUTOMATIC_MODULE_NAME="commons.math3"