summaryrefslogtreecommitdiff
path: root/dev-java/commons-math/commons-math-3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/commons-math/commons-math-3.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/commons-math/commons-math-3.2.ebuild')
-rw-r--r--dev-java/commons-math/commons-math-3.2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/commons-math/commons-math-3.2.ebuild b/dev-java/commons-math/commons-math-3.2.ebuild
new file mode 100644
index 000000000000..7d4b8f2dc93e
--- /dev/null
+++ b/dev-java/commons-math/commons-math-3.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+# Tests are currently broken due to nasty -lib argument.
+JAVA_PKG_IUSE="doc source" # test
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
+HOMEPAGE="https://commons.apache.org/math/"
+SRC_URI="mirror://apache/commons/math/source/${MY_P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="amd64 x86"
+
+DEPEND=">=virtual/jdk-1.5"
+
+# Tests are currently broken due to nasty -lib argument.
+# test? (
+# dev-java/ant-junit4
+# dev-java/hamcrest-core:0
+# )"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${MY_P}-src"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ sed -i 's/manifest=".*MANIFEST.MF"//g' build.xml || die
+ sed -i '/name="Main-Class"/d' build.xml || die
+}
+
+# Tests are currently broken due to nasty -lib argument.
+# src_test() {
+# java-pkg_jar-from junit-4
+# java-pkg_jar-from hamcrest-core
+# ANT_TASKS="ant-junit4" eant -Djunit.jar=junit.jar test
+# }
+
+src_install() {
+ java-osgi_newjar target/${MY_P}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+}