summaryrefslogtreecommitdiff
path: root/dev-java/commons-jelly
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/commons-jelly
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/commons-jelly')
-rw-r--r--dev-java/commons-jelly/Manifest4
-rw-r--r--dev-java/commons-jelly/commons-jelly-1.0-r8.ebuild63
-rw-r--r--dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch59
-rw-r--r--dev-java/commons-jelly/metadata.xml8
4 files changed, 134 insertions, 0 deletions
diff --git a/dev-java/commons-jelly/Manifest b/dev-java/commons-jelly/Manifest
new file mode 100644
index 000000000000..02c52ccc412c
--- /dev/null
+++ b/dev-java/commons-jelly/Manifest
@@ -0,0 +1,4 @@
+AUX commons-jelly-1.0-gentoo.patch 2224 BLAKE2B bc79266243cf9016690cecfc414076f4aaa67a8b10074ccd77971c4b8f00d251315712d8769ef58c188cb67f3534b16946beabbb3c31d3d2601eb7b018949629 SHA512 726b64273320f1a089ce9d9b8121359cc377e070ce4b49155de52ce31559d0601b137fb6e208b8c5ab696c64224047592c26957ad3d7a49dc390b523c821f7b5
+DIST commons-jelly-1.0-src.tar.gz 174769 BLAKE2B 2dc43eef28c76252976616f0509aacbfed31ec0b99916730d86d084ec54bacc4f49000d04a953002717670d17a4ae2ae7249d57b327258414c3515dbb8abde7f SHA512 a72ae2dc8eea3fc19838f386dca38807a16326a3a93f483219212844f8ec033088b7721c78a4370f78a06cbee0c685144a2b16f171d54134822d06f653bcef35
+EBUILD commons-jelly-1.0-r8.ebuild 1539 BLAKE2B 09c197747867e4ffe01db3ac58a63dbefdb4ade35a1d2ccd10882ce2055e35c23ddde0ef9cbbdffbb51d10fbccce2bb1e8f16aa952d04cd559c81c79c91aff77 SHA512 b6cffabfdb0087b8a42492d19e413093e65d3146f0843ab8246791509376d1870996acabc9dd9e9eb9807993957f962f663b7c03ab779d4fbbfa6663c7a8a504
+MISC metadata.xml 232 BLAKE2B 513679b02247d8e4cb4c874abd785119d9ca62ad24c44969d52a42c3765d0ebf689024512a2c4c48e69688a4ce02a74ae05708b050a720bc73d8d2bf2ceff58d SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893
diff --git a/dev-java/commons-jelly/commons-jelly-1.0-r8.ebuild b/dev-java/commons-jelly/commons-jelly-1.0-r8.ebuild
new file mode 100644
index 000000000000..00885443116b
--- /dev/null
+++ b/dev-java/commons-jelly/commons-jelly-1.0-r8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P}-src"
+DESCRIPTION="A Java and XML based scripting and processing engine"
+HOMEPAGE="http://commons.apache.org/jelly/"
+SRC_URI="mirror://apache/jakarta/commons/jelly/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-java/dom4j:1
+ dev-java/junit:0
+ dev-java/jaxen:1.1
+ dev-java/commons-cli:1
+ dev-java/commons-lang:0
+ dev-java/commons-jexl:1.0
+ dev-java/commons-logging:0
+ dev-java/commons-discovery:0
+ dev-java/commons-collections:0
+ dev-java/commons-beanutils:1.7
+ dev-java/tomcat-jstl-spec:0
+ java-virtuals/servlet-api:3.0"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6
+ test? ( dev-java/ant-junit:0 )"
+
+S=${WORKDIR}/${MY_P}
+
+java_prepare() {
+ # disables dependency fetching, and remove tests as a dependency of jar
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_EXTRA_ARGS="-Dlibdir=."
+EANT_GENTOO_CLASSPATH="
+ commons-beanutils-1.7,commons-cli-1,commons-collections,commons-discovery
+ commons-jexl-1.0,commons-lang,commons-logging,dom4j-1,tomcat-jstl-spec
+ jaxen-1.1,junit,servlet-api-3.0"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+ dodoc NOTICE.txt README.txt RELEASE-NOTES.txt || die
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
new file mode 100644
index 000000000000..8fafca81ea79
--- /dev/null
+++ b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
@@ -0,0 +1,59 @@
+diff -ru commons-jelly-1.0-src/build.xml commons-jelly-1.0-src-patched/build.xml
+--- commons-jelly-1.0-src/build.xml 2005-06-16 10:39:44.000000000 -0400
++++ commons-jelly-1.0-src-patched/build.xml 2005-09-04 19:39:19.000000000 -0400
+@@ -37,6 +37,8 @@
+ <property name="proxy.password" value="">
+ </property>
+ <path id="build.classpath">
++ <fileset dir="${libdir}" includes="**/*.jar"/>
++ <!--
+ <pathelement location="${libdir}/servletapi/jars/servletapi-2.3.jar">
+ </pathelement>
+ <pathelement location="${libdir}/commons-cli/jars/commons-cli-1.0.jar">
+@@ -67,6 +69,7 @@
+ </pathelement>
+ <pathelement location="${libdir}/xerces/jars/xerces-2.2.1.jar">
+ </pathelement>
++ -->
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}">
+@@ -92,7 +95,7 @@
+ </and>
+ </condition>
+ </target>
+- <target name="compile" description="o Compile the code" depends="get-deps">
++ <target name="compile" description="o Compile the code" depends="">
+ <mkdir dir="${classesdir}">
+ </mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+@@ -120,10 +123,12 @@
+ <copy todir="${classesdir}/META-INF" file="${basedir}/LICENSE.txt">
+ </copy>
+ </target>
+- <target name="jar" description="o Create the jar" depends="compile,test">
++
++ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
+ </jar>
+ </target>
++
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}">
+ </delete>
+@@ -213,7 +218,7 @@
+ </fileset>
+ </copy>
+ </target>
+- <target name="javadoc" description="o Generate javadoc" depends="get-deps">
++ <target name="javadoc" description="o Generate javadoc" depends="">
+ <mkdir dir="${javadocdir}">
+ </mkdir>
+ <tstamp>
+@@ -432,4 +437,4 @@
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+-</project>
+\ No newline at end of file
++</project>
diff --git a/dev-java/commons-jelly/metadata.xml b/dev-java/commons-jelly/metadata.xml
new file mode 100644
index 000000000000..2444066aa02b
--- /dev/null
+++ b/dev-java/commons-jelly/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+</pkgmetadata>