summaryrefslogtreecommitdiff
path: root/dev-java/commons-graph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/commons-graph
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/commons-graph')
-rw-r--r--dev-java/commons-graph/Manifest6
-rw-r--r--dev-java/commons-graph/commons-graph-0.1.ebuild47
-rw-r--r--dev-java/commons-graph/files/commons-graph-0.1-build.xml258
-rw-r--r--dev-java/commons-graph/metadata.xml8
4 files changed, 319 insertions, 0 deletions
diff --git a/dev-java/commons-graph/Manifest b/dev-java/commons-graph/Manifest
new file mode 100644
index 000000000000..40e8c84b30e0
--- /dev/null
+++ b/dev-java/commons-graph/Manifest
@@ -0,0 +1,6 @@
+AUX commons-graph-0.1-build.xml 11134 SHA256 d1d9a17692858aabe1a75c0f1a9d8de7d6cf7062d26b37e313d90dcf08d4df92 SHA512 a2ab4d7cccdf79b94ee5af661039cb520d7c16f8a868f00d6e2329286690edad94fd162eafa650daa411912b8f888e81e809184b94124f1c9436d0bdd009b160 WHIRLPOOL 1a14d08cca71fe103406b960da0d6507ee40e1ff77a85cbc76e5ea99686608ac57830a3ef6fc41b8fb99c9b6d72d2aaefdb8e108315049229f30f5e05dcba2b5
+DIST commons-graph-0.1.tar.gz 96009 SHA256 b68f5c7132e9eea4872dfc0d5fd74c138d2489355540dff752a91311cbac040d SHA512 7214fd60eb348a7feee9c194f562e5a7cf1f211ba589d2a85eaae52ed3ced7089842405dfbd99413b1f06f87ea1a19d244989daa1e0f6fb857fa752647d52b16 WHIRLPOOL 90c014761b2a1f8572eba4339f2ea81ec34666a83c21ea27326b366f0089cc5f20a5d6bc53aefa1d09019114b34f424496af95a604c1b55b5bdfec879ab51a0b
+EBUILD commons-graph-0.1.ebuild 1104 SHA256 f122b130e1feee7c9b49de43ded4335dbf305371cb50afa1ced29b7bde782c99 SHA512 b15984281bd5662631daef2524984c2a9727f5851170ad17bef8f50fb2234f911584a302bd2ca19933428a4f4e851dafb3ecaa27903430355538ce6a59b24c0c WHIRLPOOL 7cfef90f3c735d1bda34a3b17e2bd663538c27b717e054122a2b2f8cbf4eb4665b65bdf06639ecc1c0fa898d8bfaa4638e4d54dde0426f90f8bd7ed2058803ac
+MISC ChangeLog 3443 SHA256 ab640e262a371c9ae4e6f5ee22c9df80e0cc981e5ffbb1baf58359f7e651cbf2 SHA512 b5b376770aa4ac7353188fe169541eb9f1546a54620e0a814a0aa3dc10af5a3d01349ffbea66bc5f5875f988424f67598092fd5400a696b02a9e2c1f57a5b7a4 WHIRLPOOL 44bfdd7c068a4bebcb3896c2f418395c366c371c8c82a15b1db0f1ebad962731ff93e496f72c123f711525772d9a00c0254ab07c835662cc1b10b4933d8d6aa3
+MISC ChangeLog-2015 1444 SHA256 8b38392628bd2e1fa583a87836e493cf76f94e9394e1f11225d9c57ed942dfe7 SHA512 d84a8fe839f242151239c881b6fd4ff4a08562f1d68e8388116955ae546646e575551532df58cc8b40f06f52e90b7917ba278a9e72ad8fce1882480f54b0a947 WHIRLPOOL 5630b8c174764d43dc59d0cfc4fa81524b1af21fd6d9f051ef4a84bccc8652f20f71b412cc978f6a08548741f3ccb5eb96e8c594d85156db44c02d01d2af6a04
+MISC metadata.xml 232 SHA256 0c8d91b3d514ac42d0eaca567346ab909c0f947049c85c25a380ec2400f1b3fb SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893 WHIRLPOOL 3a1a6d054edc9177d85ca868f9b0a6e84ee51bab4fbdbb9b1ead1a03874036bcc3f96e903fb751dc4d29fdb7d6b5f3d8dbe7b042fc697c887e23f41cc9c8c4ac
diff --git a/dev-java/commons-graph/commons-graph-0.1.ebuild b/dev-java/commons-graph/commons-graph-0.1.ebuild
new file mode 100644
index 000000000000..d62104317f83
--- /dev/null
+++ b/dev-java/commons-graph/commons-graph-0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A toolkit for managing graphs and graph based data structures"
+HOMEPAGE="https://commons.apache.org/sandbox/commons-graph/"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ )"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_TEST_TARGET="test"
+
+# Dubious tests.
+JAVA_RM_FILES=(
+ src/test/java/org/apache/commons/graph/coloring/GraphColoringTestCase.java
+ src/test/java/org/apache/commons/graph/spanning/KruskalTestCase.java
+ src/test/java/org/apache/commons/graph/scc/TarjanTestCase.java
+)
+
+java_prepare() {
+ cp "${FILESDIR}"/"${P}-build.xml" build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}
diff --git a/dev-java/commons-graph/files/commons-graph-0.1-build.xml b/dev-java/commons-graph/files/commons-graph-0.1-build.xml
new file mode 100644
index 000000000000..5c3a9c19cdd4
--- /dev/null
+++ b/dev-java/commons-graph/files/commons-graph-0.1-build.xml
@@ -0,0 +1,258 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 10/6/15 9:24 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-graph-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-graph-0.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/com/carrotsearch/junit-benchmarks/0.3.0/junit-benchmarks-0.3.0-jdk15.jar"/>
+ <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
+ <pathelement location="${maven.repo.local}/com/h2database/h2/1.3.158/h2-1.3.158.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
+ <copy todir="${maven.build.testOutputDir}/META-INF">
+ <fileset dir="${maven.build.testResourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ <exclude name="**/TestRunner.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="iso-8859-1"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.6"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/6/docs/api/"/>
+ <link href="http://download.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class" value="Main"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/commons-graph/metadata.xml b/dev-java/commons-graph/metadata.xml
new file mode 100644
index 000000000000..2444066aa02b
--- /dev/null
+++ b/dev-java/commons-graph/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+</pkgmetadata>