summaryrefslogtreecommitdiff
path: root/dev-java/commons-graph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/commons-graph
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/commons-graph')
-rw-r--r--dev-java/commons-graph/Manifest4
-rw-r--r--dev-java/commons-graph/commons-graph-0.1.ebuild47
-rw-r--r--dev-java/commons-graph/files/commons-graph-0.1-build.xml258
-rw-r--r--dev-java/commons-graph/metadata.xml8
4 files changed, 0 insertions, 317 deletions
diff --git a/dev-java/commons-graph/Manifest b/dev-java/commons-graph/Manifest
deleted file mode 100644
index a52b50dbc8a0..000000000000
--- a/dev-java/commons-graph/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX commons-graph-0.1-build.xml 11134 BLAKE2B 6a50f6ebc8e4efdf2aec653034d0f448d5e4f7a760d374c0c25a871225ab9f2e5cec1e4c1999b93f53cf16102ea6b15f70b3a94ea37e50b348438d6683e0e624 SHA512 a2ab4d7cccdf79b94ee5af661039cb520d7c16f8a868f00d6e2329286690edad94fd162eafa650daa411912b8f888e81e809184b94124f1c9436d0bdd009b160
-DIST commons-graph-0.1.tar.gz 96009 BLAKE2B 0914bebc5e4748a619396a5abc78c78edfce95d5c475d988185ea9d1735d57145a27b9139e91628e06c28c9adbb174945f1db9f21a605cb4dea305aae2064eaa SHA512 7214fd60eb348a7feee9c194f562e5a7cf1f211ba589d2a85eaae52ed3ced7089842405dfbd99413b1f06f87ea1a19d244989daa1e0f6fb857fa752647d52b16
-EBUILD commons-graph-0.1.ebuild 1104 BLAKE2B aeda64cc1c3b4bcd99ef73d5548e23ed8278328da6dc6fd639ebe6ba9e7d2606c2773174da5648b839f0303dff37833c86c444b26a51c98bb695fffdabd64ab9 SHA512 b15984281bd5662631daef2524984c2a9727f5851170ad17bef8f50fb2234f911584a302bd2ca19933428a4f4e851dafb3ecaa27903430355538ce6a59b24c0c
-MISC metadata.xml 232 BLAKE2B 513679b02247d8e4cb4c874abd785119d9ca62ad24c44969d52a42c3765d0ebf689024512a2c4c48e69688a4ce02a74ae05708b050a720bc73d8d2bf2ceff58d SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893
diff --git a/dev-java/commons-graph/commons-graph-0.1.ebuild b/dev-java/commons-graph/commons-graph-0.1.ebuild
deleted file mode 100644
index d62104317f83..000000000000
--- a/dev-java/commons-graph/commons-graph-0.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="A toolkit for managing graphs and graph based data structures"
-HOMEPAGE="https://commons.apache.org/sandbox/commons-graph/"
-SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=">=virtual/jdk-1.6
- test? (
- dev-java/ant-junit:0
- )"
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-EANT_TEST_TARGET="test"
-
-# Dubious tests.
-JAVA_RM_FILES=(
- src/test/java/org/apache/commons/graph/coloring/GraphColoringTestCase.java
- src/test/java/org/apache/commons/graph/spanning/KruskalTestCase.java
- src/test/java/org/apache/commons/graph/scc/TarjanTestCase.java
-)
-
-java_prepare() {
- cp "${FILESDIR}"/"${P}-build.xml" build.xml || die
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java
-}
diff --git a/dev-java/commons-graph/files/commons-graph-0.1-build.xml b/dev-java/commons-graph/files/commons-graph-0.1-build.xml
deleted file mode 100644
index 5c3a9c19cdd4..000000000000
--- a/dev-java/commons-graph/files/commons-graph-0.1-build.xml
+++ /dev/null
@@ -1,258 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 10/6/15 9:24 AM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="commons-graph-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="commons-graph-0.1"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.build.testResourceDir.1" value="."/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/4.10/junit-4.10.jar"/>
- <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
- <pathelement location="${maven.repo.local}/com/carrotsearch/junit-benchmarks/0.3.0/junit-benchmarks-0.3.0-jdk15.jar"/>
- <pathelement location="${maven.repo.local}/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar"/>
- <pathelement location="${maven.repo.local}/com/h2database/h2/1.3.158/h2-1.3.158.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="iso-8859-1"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.0}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- encoding="iso-8859-1"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
- <copy todir="${maven.build.testOutputDir}/META-INF">
- <fileset dir="${maven.build.testResourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- <exclude name="**/TestRunner.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- encoding="iso-8859-1"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- source="1.6"
- linksource="true"
- breakiterator="false">
- <link href="http://download.oracle.com/javase/6/docs/api/"/>
- <link href="http://download.oracle.com/javaee/6/api/"/>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- <manifest>
- <attribute name="Main-Class" value="Main"/>
- </manifest>
- </jar>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
-</project>
diff --git a/dev-java/commons-graph/metadata.xml b/dev-java/commons-graph/metadata.xml
deleted file mode 100644
index 2444066aa02b..000000000000
--- a/dev-java/commons-graph/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
-</pkgmetadata>