summaryrefslogtreecommitdiff
path: root/dev-java/commons-email
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/commons-email
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/commons-email')
-rw-r--r--dev-java/commons-email/Manifest5
-rw-r--r--dev-java/commons-email/commons-email-1.4.ebuild53
-rw-r--r--dev-java/commons-email/files/commons-email-1.4-build.xml261
-rw-r--r--dev-java/commons-email/metadata.xml8
4 files changed, 327 insertions, 0 deletions
diff --git a/dev-java/commons-email/Manifest b/dev-java/commons-email/Manifest
new file mode 100644
index 000000000000..d223f6209941
--- /dev/null
+++ b/dev-java/commons-email/Manifest
@@ -0,0 +1,5 @@
+AUX commons-email-1.4-build.xml 10956 SHA256 17a612ef2fffb3de5e3f2c540b993d144640615cf14f76881b52cda322277823 SHA512 2555322efb15f1f4d26d78bea3638ae20b002c431891ec5ab8a45ef88df23b67f0ac0caf3fbba17e8f32fc2474eb09ae481bed05eb2b612386f31df5b0007cdb WHIRLPOOL ed221ce5e9a78b6e709d606cf5f78f8a1cf917b55cf15611865305d4dcb8f55e89cc66c83ada465aa902c2cfb507590c22b337ee4daf23214d6e1e7582d9a01b
+DIST commons-email-1.4-src.tar.gz 288876 SHA256 bf86115adc3e724c3e713102874d4ca686e7e6e34f9856438655be5a4c008cb0 SHA512 2a62256e284b9f4f428cf8544e46e81aa521476c41243df1c4f8a9e1bd4bcea3c768346aaab862b8c2a8b271c6012a38164c6d62867d2849a3ee0c2820fe422c WHIRLPOOL aaca35bd39e09020653af31b8147d1c323b80a7805199cb060327b0558c4ebbd86381a851edc06c63ed8bbc328a770d90e032c2edc302a6aca58b3624b6beab6
+EBUILD commons-email-1.4.ebuild 1089 SHA256 a4a65d818c08cb0779f4f2a4e3c4638d68e48e85e48113ebd4f592a34cf72f76 SHA512 a85d7e3ec14da9425519bf15ba4f4e576fcf9ed0dc5c3482ed9ecde53168ea067b16bf0aef6b06668ff0b6a0a224a20b1943c3a834b73764b870b52676cddb83 WHIRLPOOL edafbc21013a9aa20a3bc6b8ed784aa360e56f91d156855c7251029c00e9aa18858f6d5748e2f2e14fdaaabce1a1f1230e93351db0a41ffdf1a8d52f28688277
+MISC ChangeLog 1360 SHA256 14d06eabc74c623ffcde7d0a3af1df7226340175f48a1913f70ae347e4baf6b4 SHA512 38fe80d6e9821a0695d22bf15e3dc1c97b69559f076850866579bb2e15abcd1587dc7a9cb2fc0004bbb30a95200cf58a29048f41fcae67c28daeacec8d64042b WHIRLPOOL 25e8cec915a38a2cd977ce67b0b07cfdc3b20e2a1fa79644a7465435b3539f23c007d6d1e96228663750704a1ee61fd4c7da90f3eff4e7467d8a455b491d3fa8
+MISC metadata.xml 236 SHA256 3e778d35b34b5cc1a4dd7ce105fe7d2a99b25fb6dfe24709455da94baa8a0548 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253 WHIRLPOOL 7967660784d0d28e9a3c3c222c5bf85b3a8b59fd84b61780e4e7cc1aa5d8bd87bee40e4c5c42e646f15d6641fe182340bcbe8be94c785f40e0ac870c7a96e5cc
diff --git a/dev-java/commons-email/commons-email-1.4.ebuild b/dev-java/commons-email/commons-email-1.4.ebuild
new file mode 100644
index 000000000000..ebcea82ec21e
--- /dev/null
+++ b/dev-java/commons-email/commons-email-1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="source doc test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Email aims to provide an API for sending email."
+HOMEPAGE="http://commons.apache.org/email/"
+SRC_URI="mirror://apache/commons/email/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+# Requires a slew of packages we don't ship yet.
+RESTRICT="test"
+
+CDEPEND="dev-java/oracle-javamail:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-java/ant-junit:0
+ )
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_GENTOO_CLASSPATH="oracle-javamail"
+EANT_BUILD_TARGET="package"
+
+java_prepare() {
+ cp "${FILESDIR}/${P}-build.xml" build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "target/${P}.jar" "${PN}.jar"
+ dodoc {NOTICE,README,RELEASE-NOTES}.txt || die
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}
diff --git a/dev-java/commons-email/files/commons-email-1.4-build.xml b/dev-java/commons-email/files/commons-email-1.4-build.xml
new file mode 100644
index 000000000000..9fb5f0e373bf
--- /dev/null
+++ b/dev-java/commons-email/files/commons-email-1.4-build.xml
@@ -0,0 +1,261 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 9/29/15 9:53 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-email-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-email-1.4"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
+ <copy todir="${maven.build.testOutputDir}/META-INF">
+ <fileset dir="${maven.build.testResourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="org/apache/commons/mail/mocks/*"/>
+ <exclude name="org/apache/commons/mail/settings/*"/>
+ <exclude name="**/Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="org/apache/commons/mail/mocks/*"/>
+ <exclude name="org/apache/commons/mail/settings/*"/>
+ <exclude name="**/Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ docencoding="UTF-8"
+ source="1.6"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://docs.oracle.com/javase/7/docs/api/"/>
+ <link href="http://docs.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class" value="Main"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/commons-email/metadata.xml b/dev-java/commons-email/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/commons-email/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>