summaryrefslogtreecommitdiff
path: root/dev-java/commons-codec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/commons-codec
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/commons-codec')
-rw-r--r--dev-java/commons-codec/Manifest6
-rw-r--r--dev-java/commons-codec/commons-codec-1.11.ebuild54
-rw-r--r--dev-java/commons-codec/commons-codec-1.7.ebuild41
-rw-r--r--dev-java/commons-codec/files/commons-codec-1.11-build.xml200
-rw-r--r--dev-java/commons-codec/metadata.xml29
5 files changed, 0 insertions, 330 deletions
diff --git a/dev-java/commons-codec/Manifest b/dev-java/commons-codec/Manifest
deleted file mode 100644
index b8333b15b303..000000000000
--- a/dev-java/commons-codec/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX commons-codec-1.11-build.xml 8949 BLAKE2B f1a5dfadeebbc183c075d96a8769218e98745936b45d38de1d0da8034a052ca99c3def82c2360857849ba7daefa1bf5d7aae1288ec71505de7154b0ab9e87aef SHA512 fc22470e625e7405308d2a21f0dbdf4bf565cc8db623bb3c4dba08d55da3a0884bc3da744cd029716af2ba51d708d0ed309f7c6a21a7df6f0e5027d5c6f646a5
-DIST commons-codec-1.11.tar.gz 369538 BLAKE2B 6b77cb3c69c81a9684b298ac5233b788d6651ecc96b70ac7fda9face5af5a60970c5bb2531fd285d20dce7732829f7470b9e4941d63025faf47247410f1ffba2 SHA512 b3159308f28b2fc50208421412d8cc81f439cc07dc3d071df7b50f2d862aab65b3d20bc8eb2906367a05ecf5138c56b5f12c6cf9c224def8b8286fe12ac5346f
-DIST commons-codec-1.7-src.tar.gz 291251 BLAKE2B b8fecdb9b88a21ceb3106a13332493617ecd2c8064c84a1514dec1c1c254e18116ff4926f7445bef4171000ba77da411efd6a93fe80a4795e887832035373e10 SHA512 31358283ac2827cb05486b8ff1512242153f61deb086f7fe145ee3ca38d96e43fba080a1e89a3b8cd44d09761015ff4dbe5226d29b7f9fcd59e68ca7701b28d6
-EBUILD commons-codec-1.11.ebuild 1048 BLAKE2B f742d3ac245d6561e53fef06b73472ccde6ea21ce33e5b26777f74db1ca92d6788d782e3e38ed4a972bc1cb41595cc82f23674d8b47d1a54ddd259d93999dca2 SHA512 ec45f17ca4f6517343389136407dc1ef5745b7ffef3d7e69f69c8f0139e470ae7d59ba1bc77dc894e39a864520ab0e7ba50685b334ee40e054fb8034c6aec607
-EBUILD commons-codec-1.7.ebuild 895 BLAKE2B 25171d147e9638b88f210f02b6e12d13e6c391b51191a1c00ab118cac8e4fba1a063e824ab852500fcb2a99081378c81e12317d31349f8e0e6c15a9ceeceeb41 SHA512 d842c00d962bfbd508e893aa14e303ad74f9d5e9afdd85ab9df7ee67ffad174dc77d950328333566e29eaf04c5402b95a1080439724579cd4bd0209102945619
-MISC metadata.xml 1360 BLAKE2B 5e996a35877486521352b61fdb44872970caab9497267c9d95d1364bd299838486f1853b46f35ec140259d33e7158bca7224488f21c388caa4fa9e7a153006bb SHA512 d16f70860d4880e50d25e6297823fb71955c147eedd115ca7eda0a0bf6c4cbc6121bf8b12062241192facd4583f10df56a838c84940b5914f75d13f10c96e9ae
diff --git a/dev-java/commons-codec/commons-codec-1.11.ebuild b/dev-java/commons-codec/commons-codec-1.11.ebuild
deleted file mode 100644
index 7abed459fb4e..000000000000
--- a/dev-java/commons-codec/commons-codec-1.11.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Implementations of common encoders and decoders in Java"
-HOMEPAGE="https://commons.apache.org/codec"
-SRC_URI="mirror://apache/commons/codec/source/${P}-src.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="test"
-
-RDEPEND="
- >=virtual/jre-1.6"
-
-DEPEND="
- >=virtual/jdk-1.6
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S="${WORKDIR}/${P}-src"
-
-JAVA_ANT_ENCODING="ISO-8859-1"
-EANT_TEST_GENTOO_CLASSPATH="junit-4"
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-RESTRICT="test"
-
-DOCS=( RELEASE-NOTES.txt NOTICE.txt )
-
-src_prepare() {
- cp "${FILESDIR}/${P}-build.xml" "${S}/build.xml" || die
- default
-}
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar "target/${P}.jar"
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/*
-}
diff --git a/dev-java/commons-codec/commons-codec-1.7.ebuild b/dev-java/commons-codec/commons-codec-1.7.ebuild
deleted file mode 100644
index 8a328da43bbc..000000000000
--- a/dev-java/commons-codec/commons-codec-1.7.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Implementations of common encoders and decoders in Java"
-HOMEPAGE="http://commons.apache.org/codec"
-SRC_URI="mirror://apache/commons/codec/source/${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="test"
-
-RDEPEND=">=virtual/jre-1.6"
-DEPEND=">=virtual/jdk-1.6
- test? (
- dev-java/ant-junit:0
- dev-java/junit:4
- )"
-
-S=${WORKDIR}/${P}-src
-
-JAVA_ANT_ENCODING="ISO-8859-1"
-EANT_TEST_GENTOO_CLASSPATH="junit-4"
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar dist/${P}*.jar
-
- dodoc RELEASE-NOTES.txt
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc src/main/java/*
-}
diff --git a/dev-java/commons-codec/files/commons-codec-1.11-build.xml b/dev-java/commons-codec/files/commons-codec-1.11-build.xml
deleted file mode 100644
index 251268136bf8..000000000000
--- a/dev-java/commons-codec/files/commons-codec-1.11-build.xml
+++ /dev/null
@@ -1,200 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 5/27/18 9:10 AM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="commons-codec-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="commons-codec-1.11"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.resourceDir.1" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.build.testResourceDir.1" value="."/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/4.12/junit-4.12.jar"/>
- <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
- <pathelement location="${maven.repo.local}/org/apache/commons/commons-lang3/3.5/commons-lang3-3.5.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="UTF-8"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}"/>
- </copy>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.1}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*AbstractTest.java"/>
- <exclude name="**/*PerformanceTest.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*AbstractTest.java"/>
- <exclude name="**/*PerformanceTest.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- encoding="UTF-8"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- docencoding="UTF-8"
- source="1.6"
- linksource="true"
- breakiterator="false">
- <link href="http://docs.oracle.com/javase/7/docs/api/"/>
- <link href="http://docs.oracle.com/javaee/6/api/"/>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <!--
- <target name="package" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- manifest="/var/tmp/portage/dev-java/commons-codec-1.11/work/commons-codec-1.11-src/target/osgi/MANIFEST.MF"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- <manifest>
- <attribute name="Main-Class"/>
- </manifest>
- </jar>
- </target>
- -->
-
- <target name="package" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html">
- </jar>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
-</project>
diff --git a/dev-java/commons-codec/metadata.xml b/dev-java/commons-codec/metadata.xml
deleted file mode 100644
index f27bbde4a60f..000000000000
--- a/dev-java/commons-codec/metadata.xml
+++ /dev/null
@@ -1,29 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
-
-<longdescription>
-Codec was formed as an attempt to focus development effort on one
-definitive implementation of the Base64 encoder. At the time of Codec's
-proposal, there were approximately 34 different Java classes that dealt
-with Base64 encoding spread over the Foundation's CVS repository.
-Developers in the Jakarta Tomcat project had implemented an original
-version of the Base64 codec which had been copied by the Commons
-HttpClient and Apache XML project's XML-RPC subproject. After almost one
-year, the two forked versions of Base64 had significantly diverged from
-one another. XML-RPC had applied numerous fixes and patches which were
-not applied to the Commons HttpClient Base64. Different subprojects had
-differing implementations at various levels of compliance with the RFC
-2045.
-
-Out of that confusing duplication of effort sprang this simple attempt
-to encourage code reuse among various projects. While this package
-contains a abstract framework for the creation of encoders and decoders,
-Codec itself is primarily focused on providing functional utilities for
-working with common encodings.
-</longdescription>
-</pkgmetadata>