summaryrefslogtreecommitdiff
path: root/dev-java/commons-chain
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/commons-chain
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/commons-chain')
-rw-r--r--dev-java/commons-chain/Manifest6
-rw-r--r--dev-java/commons-chain/commons-chain-1.2.ebuild65
-rw-r--r--dev-java/commons-chain/files/commons-chain-1.2-build.xml215
-rw-r--r--dev-java/commons-chain/metadata.xml8
4 files changed, 294 insertions, 0 deletions
diff --git a/dev-java/commons-chain/Manifest b/dev-java/commons-chain/Manifest
new file mode 100644
index 000000000000..c95c80107912
--- /dev/null
+++ b/dev-java/commons-chain/Manifest
@@ -0,0 +1,6 @@
+AUX commons-chain-1.2-build.xml 8492 SHA256 4d9e538088c2f574b26d9c42e65230c0718300d227bf860e1ffe020b57e752cb SHA512 7e9ec638693b5875cd2f0c0fe45cc3d5bd7029fb599f277565f195538dde981e1e1dc7f615f1a296a264a353d0b55dab2ca489a4f735c4500e50c25f45488b64 WHIRLPOOL 367f6ca4abd0ea052e1dcd58d2a6d74d67632e5786ad33d754415c0a0a77e76c74cd08cc69189ca59c3d852cc29f8980818c4bdad33ad01e83043baa413dc585
+DIST commons-chain-1.2-src.zip 316195 SHA256 6c13dd2c5fddffc6e955a702eb8767d9ebb8e3aa1f8d696bf2933a77a8c13ad3 SHA512 454cc3c00deb78f0c07e01ea5e2be9ea1210b7a0162e2490e5aba0df0788e1661aed88e4c4ac83e9f2046f62bdf063ecb7af7d3d49b7e87056aded1d5c1dad4b WHIRLPOOL aa2b6e2253493289f0e4599af71c1bf1361aa4cf17720f1498d6b991fee1bad963db6d307ab052b2b99f9d2e073d967e06ee54b45debf045b558a20ae24593d7
+EBUILD commons-chain-1.2.ebuild 1347 SHA256 6b04580da862fb42d17fca3dc03b6db8c38981fb4af2e7a779fec4589efef574 SHA512 0ba9e18f69c771078b3ef032eb17a63910af2d463da48070e48ffd8fc9f22b6e1399215b9ab25e501592b4ae220408fe8f38d1967c52cbf276e846e723ed1363 WHIRLPOOL 96ea6a735871123f9b0a87a69c71dd8b19a115fc94697c3fbde0f80105fe6bc5eb2b0f228a8b521c8a25590786e9a2b746da797ec3e112569e0b66ac3ee54fd3
+MISC ChangeLog 2909 SHA256 f6556b889a3e2fb51771ac2014d4f7ee4c918a4b17ca4354bc2d55e1ca720198 SHA512 84786a99c195a53aef14600e4c5bcf5477e33f7c79eed5ccbba12acd8160841d6833d0619f08d7bf8bd7882abb8c26d01a1bbaa535c7c186989ba91577c3af27 WHIRLPOOL 37ad2faab9850c3d35ca274d535f100fbc04a323e17bf797e687ab7d92bd82baea1ea7bec3db1a0cd076705e680e4d8a1bc377a4b69470f7a86db954be63df64
+MISC ChangeLog-2015 443 SHA256 b0f7068707b9d7fa0b1b8e20c6debcf642c433b58d0b5c54385e9e99bc68bf53 SHA512 9ae71fcafb89520edbf8ccbb707d6d07cf4c3711a33a4e80ce4fbb50ca972a3caebecfea97f783b30484f9f1f57b0b5b2075626c1696042edec1958cae6b8441 WHIRLPOOL 149687d4b79dd0ac0a5e4891db6486337e63ab473892d63b3be7fa725d811a5ecc77a53a2b803a0e0480bc214d1d1e22e12f305addb48200497c837ec317e5c5
+MISC metadata.xml 236 SHA256 3e778d35b34b5cc1a4dd7ce105fe7d2a99b25fb6dfe24709455da94baa8a0548 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253 WHIRLPOOL 7967660784d0d28e9a3c3c222c5bf85b3a8b59fd84b61780e4e7cc1aa5d8bd87bee40e4c5c42e646f15d6641fe182340bcbe8be94c785f40e0ac870c7a96e5cc
diff --git a/dev-java/commons-chain/commons-chain-1.2.ebuild b/dev-java/commons-chain/commons-chain-1.2.ebuild
new file mode 100644
index 000000000000..18ee9cf7307a
--- /dev/null
+++ b/dev-java/commons-chain/commons-chain-1.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P}-src"
+DESCRIPTION="API exposing the Chain of Responsability design pattern - by the ASF"
+HOMEPAGE="http://commons.apache.org/proper/commons-chain/"
+SRC_URI="mirror://apache/commons/chain/source/${MY_P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+# Too many missing imports from javax.servlet.* which causes the
+# "compile-tests" target to fail compiling.
+# I gave up on them after wasting nearly half a day.
+RESTRICT="test"
+
+IUSE=""
+
+CDEPEND="dev-java/commons-digester:0
+ dev-java/mojarra:2.2
+ dev-java/portletapi:2.0
+ dev-java/commons-logging:0
+ java-virtuals/servlet-api:3.0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="
+ commons-logging
+ commons-digester
+ portletapi-2.0
+ mojarra-2.2
+ servlet-api-3.0
+"
+
+EANT_BUILD_TARGET="package"
+EANT_BUILD_XML="build.xml"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml
+}
+
+src_install() {
+ java-pkg_newjar "${S}"/target/${P}.jar commons-chain.jar
+
+ if use doc; then
+ java-pkg_dohtml -r "${S}"/target/site/apidocs/
+ fi
+
+ if use source; then
+ java-pkg_dosrc "${S}"/src/*
+ fi
+}
diff --git a/dev-java/commons-chain/files/commons-chain-1.2-build.xml b/dev-java/commons-chain/files/commons-chain-1.2-build.xml
new file mode 100644
index 000000000000..1ef9f3813c7c
--- /dev/null
+++ b/dev-java/commons-chain/files/commons-chain-1.2-build.xml
@@ -0,0 +1,215 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<project name="commons-chain-1.2" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-chain-1.2"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/java"/>
+ <property name="maven.build.resourceDir.0" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test"/>
+ <property name="maven.build.testResourceDir.0" value="src/test"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="iso-8859-1"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}">
+ <include name="**/*.xml"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="iso-8859-1"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.3"
+ linksource="true"
+ failonerror="false"
+ breakiterator="false">
+ <link href="http://java.sun.com/j2se/1.4.2/docs/api/"/>
+ <link href="http://java.sun.com/j2ee/1.4/docs/api/"/>
+ <link href="http://commons.apache.org/digester/apidocs/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+</project>
diff --git a/dev-java/commons-chain/metadata.xml b/dev-java/commons-chain/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/commons-chain/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>