summaryrefslogtreecommitdiff
path: root/dev-java/commons-chain
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/commons-chain
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/commons-chain')
-rw-r--r--dev-java/commons-chain/Manifest4
-rw-r--r--dev-java/commons-chain/commons-chain-1.2.ebuild65
-rw-r--r--dev-java/commons-chain/files/commons-chain-1.2-build.xml215
-rw-r--r--dev-java/commons-chain/metadata.xml8
4 files changed, 0 insertions, 292 deletions
diff --git a/dev-java/commons-chain/Manifest b/dev-java/commons-chain/Manifest
deleted file mode 100644
index 6e96fbbe3dcc..000000000000
--- a/dev-java/commons-chain/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX commons-chain-1.2-build.xml 8492 BLAKE2B c5d967e3d789b736eeb9c6136139915a0035083f74ca166af10fb2a8d251701ea6e25d3dd9e51b297969d940a288b8ca79db7a42b8b1dd06f8640dbd4941324a SHA512 7e9ec638693b5875cd2f0c0fe45cc3d5bd7029fb599f277565f195538dde981e1e1dc7f615f1a296a264a353d0b55dab2ca489a4f735c4500e50c25f45488b64
-DIST commons-chain-1.2-src.zip 316195 BLAKE2B 4f4b6221b5358634649cced0d558cfde4e7df133bda1b3edcb1264273c879ece2332310b65f0860d07b689d371397288db0b1aae7ab76966ce7a85664f10b248 SHA512 454cc3c00deb78f0c07e01ea5e2be9ea1210b7a0162e2490e5aba0df0788e1661aed88e4c4ac83e9f2046f62bdf063ecb7af7d3d49b7e87056aded1d5c1dad4b
-EBUILD commons-chain-1.2.ebuild 1347 BLAKE2B 36838887819e8e8250bba9f646d6f1eeb6147dc9e6639030a7f441a2ab585a1db061a980a5b74a67a124a6b9cb1c1b1549c93e2a606ba7b63221ae19581459a1 SHA512 0ba9e18f69c771078b3ef032eb17a63910af2d463da48070e48ffd8fc9f22b6e1399215b9ab25e501592b4ae220408fe8f38d1967c52cbf276e846e723ed1363
-MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/commons-chain/commons-chain-1.2.ebuild b/dev-java/commons-chain/commons-chain-1.2.ebuild
deleted file mode 100644
index 18ee9cf7307a..000000000000
--- a/dev-java/commons-chain/commons-chain-1.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-MY_P="${P}-src"
-DESCRIPTION="API exposing the Chain of Responsability design pattern - by the ASF"
-HOMEPAGE="http://commons.apache.org/proper/commons-chain/"
-SRC_URI="mirror://apache/commons/chain/source/${MY_P}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# Too many missing imports from javax.servlet.* which causes the
-# "compile-tests" target to fail compiling.
-# I gave up on them after wasting nearly half a day.
-RESTRICT="test"
-
-IUSE=""
-
-CDEPEND="dev-java/commons-digester:0
- dev-java/mojarra:2.2
- dev-java/portletapi:2.0
- dev-java/commons-logging:0
- java-virtuals/servlet-api:3.0"
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-DEPEND=">=virtual/jdk-1.6
- ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="
- commons-logging
- commons-digester
- portletapi-2.0
- mojarra-2.2
- servlet-api-3.0
-"
-
-EANT_BUILD_TARGET="package"
-EANT_BUILD_XML="build.xml"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-build.xml build.xml
-}
-
-src_install() {
- java-pkg_newjar "${S}"/target/${P}.jar commons-chain.jar
-
- if use doc; then
- java-pkg_dohtml -r "${S}"/target/site/apidocs/
- fi
-
- if use source; then
- java-pkg_dosrc "${S}"/src/*
- fi
-}
diff --git a/dev-java/commons-chain/files/commons-chain-1.2-build.xml b/dev-java/commons-chain/files/commons-chain-1.2-build.xml
deleted file mode 100644
index 1ef9f3813c7c..000000000000
--- a/dev-java/commons-chain/files/commons-chain-1.2-build.xml
+++ /dev/null
@@ -1,215 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<project name="commons-chain-1.2" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="commons-chain-1.2"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/java"/>
- <property name="maven.build.resourceDir.0" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test"/>
- <property name="maven.build.testResourceDir.0" value="src/test"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath">
- </path>
- <path id="build.test.classpath">
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- encoding="iso-8859-1"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.0}">
- <include name="NOTICE.txt"/>
- <include name="LICENSE.txt"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}"
- encoding="iso-8859-1"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.6"
- verbose="false"
- fork="false"
- source="1.6">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}">
- <include name="**/*.xml"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests"
- unless="junit.skipped"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <path refid="build.test.classpath"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}" unless="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/Test*.java"/>
- <include name="**/*Test.java"/>
- <include name="**/*TestCase.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- <batchtest todir="${maven.test.reports}" if="test">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/${test}.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- encoding="iso-8859-1"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- source="1.3"
- linksource="true"
- failonerror="false"
- breakiterator="false">
- <link href="http://java.sun.com/j2se/1.4.2/docs/api/"/>
- <link href="http://java.sun.com/j2ee/1.4/docs/api/"/>
- <link href="http://commons.apache.org/digester/apidocs/"/>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
-</project>
diff --git a/dev-java/commons-chain/metadata.xml b/dev-java/commons-chain/metadata.xml
deleted file mode 100644
index 952a4b9b605c..000000000000
--- a/dev-java/commons-chain/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>