summaryrefslogtreecommitdiff
path: root/dev-java/classmate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/classmate
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/classmate')
-rw-r--r--dev-java/classmate/Manifest5
-rw-r--r--dev-java/classmate/classmate-0.9.0-r1.ebuild47
-rw-r--r--dev-java/classmate/classmate-1.0.0.ebuild52
-rw-r--r--dev-java/classmate/metadata.xml11
4 files changed, 115 insertions, 0 deletions
diff --git a/dev-java/classmate/Manifest b/dev-java/classmate/Manifest
new file mode 100644
index 000000000000..98538cafe45a
--- /dev/null
+++ b/dev-java/classmate/Manifest
@@ -0,0 +1,5 @@
+DIST classmate-0.9.0.tar.gz 57752 BLAKE2B 31247d159be4898b9ae71024da41c8602fe4d82f4ee10edab3146355cac06b23991fe926397737c43341085f35b392fc3f8a6b8278b9e47706f6fd06012f4c59 SHA512 7fb331c462458c8aab143f23c0d128a0e4e976f9d12bd181eb5658961b217bd1fe0871d056fc38bff794522c8b3118a2a017eab265afffc1d60b5580df1237a2
+DIST classmate-1.0.0.tar.gz 57807 BLAKE2B 171a82fb61fd1e183a5d435912099fd663d41c5d68791502c3a25752b77e809da817d2a8c5f8be55a211c4ab192aff6e2e566e8400c12fef688dfc05ea8a1b16 SHA512 cf721c813674e295fa6c1fe897493d14926d025cab51896ea0cec69ae285a540123060c39e3515daeffa48d6975d060861bf3ca5340bb9273980fee6d92d73b5
+EBUILD classmate-0.9.0-r1.ebuild 1153 BLAKE2B 8930a2941a6ba2dc88912ad163b6a90959b378b5589c762e35dd0a360337ba0695f554162e21bc5797cb84da76eaa5faf2e8274b35a18d978bfeb8581250bdbe SHA512 3f65f469845ed7e6d86e6f5e0473cac8d0a6c606270a0c256a01f78a5896267c975bf4b9dfbb4f36e25092c20e2baa1fc808ceb1ac18227aba3bee18ba24cfe4
+EBUILD classmate-1.0.0.ebuild 1161 BLAKE2B 2603fe68a5a76351ff3201e5e8afb8e89ffbf8e981a852b554d45022c61a5fba7c8c7a51dd0b6462d92fe732d795596c4c77f81f866a11a411e944f3f7ca0138 SHA512 d38fc03c084a8b941c8d6b6b2a8a5d07b2f092b416afc93b392c73c85eae14dd48485b223d61a14ac359c3526daf71bfe512d1080624b3d32f0562160a6a1ae3
+MISC metadata.xml 328 BLAKE2B b3f4d20d37178f91bc06a2b989603370c97231531d8221d2aed030b538e9b0a93e4ae1e906b5a2b56b6877ec175abe04e4bf7b5ef9768bbb17c88879d0721184 SHA512 ed87fc70d548ed88634183da0afb2548e74bbf5f7435edfa25e71392438df87cc1e18aa90264519009f445810ccd750626460dccb66e0f68ac844c44ba8d9430
diff --git a/dev-java/classmate/classmate-0.9.0-r1.ebuild b/dev-java/classmate/classmate-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..f6deb6b4e717
--- /dev/null
+++ b/dev-java/classmate/classmate-0.9.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple vcs-snapshot
+
+DESCRIPTION="Zero-dependency Java library for accurately introspecting type information"
+HOMEPAGE="https://github.com/cowtowncoder/java-classmate/"
+SRC_URI="https://github.com/cowtowncoder/java-classmate/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+# This one test is buggy.
+JAVA_RM_FILES=(
+ src/test/java/com/fasterxml/classmate/AnnotationsTest.java
+)
+
+java_prepare() {
+ rm pom.xml || die
+}
+
+src_test() {
+ testcp="${S}/${PN}.jar:$(java-pkg_getjars junit-4):target/tests"
+
+ mkdir target/tests || die
+ ejavac -cp "${testcp}" -d target/tests $(find src/test/java -name "*.java")
+
+ tests=$(find target/tests -name "*Test.class" -not -name "BaseTest.class" \
+ | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+ | grep -vP '\$');
+ ejunit4 -cp "${testcp}" ${tests}
+}
diff --git a/dev-java/classmate/classmate-1.0.0.ebuild b/dev-java/classmate/classmate-1.0.0.ebuild
new file mode 100644
index 000000000000..14bf78fc27ec
--- /dev/null
+++ b/dev-java/classmate/classmate-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Zero-dependency Java library for accurately introspecting type information"
+HOMEPAGE="https://github.com/cowtowncoder/java-classmate/"
+SRC_URI="https://github.com/cowtowncoder/java-classmate/archive/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ test? (
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/java-${PN}-${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+# This one test is buggy.
+JAVA_RM_FILES=(
+ src/test/java/com/fasterxml/classmate/AnnotationsTest.java
+)
+
+java_prepare() {
+ rm pom.xml || die
+}
+
+src_test() {
+ testcp="${S}/${PN}.jar:$(java-pkg_getjars junit-4):target/tests"
+
+ mkdir target/tests || die
+ ejavac -cp "${testcp}" -d target/tests $(find src/test/java -name "*.java")
+
+ tests=$(find target/tests -name "*Test.class" -not -name "BaseTest.class" \
+ | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+ | grep -vP '\$');
+ ejunit4 -cp "${testcp}" ${tests}
+}
diff --git a/dev-java/classmate/metadata.xml b/dev-java/classmate/metadata.xml
new file mode 100644
index 000000000000..b333734bceaa
--- /dev/null
+++ b/dev-java/classmate/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cowtowncoder/java-classmate</remote-id>
+ </upstream>
+</pkgmetadata>