summaryrefslogtreecommitdiff
path: root/dev-java/bytelist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/bytelist
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/bytelist')
-rw-r--r--dev-java/bytelist/Manifest4
-rw-r--r--dev-java/bytelist/bytelist-1.0.10.ebuild49
-rw-r--r--dev-java/bytelist/files/maven-build.xml219
-rw-r--r--dev-java/bytelist/metadata.xml10
4 files changed, 282 insertions, 0 deletions
diff --git a/dev-java/bytelist/Manifest b/dev-java/bytelist/Manifest
new file mode 100644
index 000000000000..88b8cb054d67
--- /dev/null
+++ b/dev-java/bytelist/Manifest
@@ -0,0 +1,4 @@
+AUX maven-build.xml 8736 BLAKE2B 6c80c5869c375da19bd15b37f8fc00a7b94d5dcb14396b3c7d42a4cbc1c6e81c3720fcfac38089ae29e492beb5aaa760d82d94d81a83149d0b8cb5e241f06ecc SHA512 1238cb1b7c53c4138f05feaa4bde6bb275d3553039940122d29df7b696945c7b021fe856b28e41c6c0fe4072b0e71280af1ba9b7f07ee8ac9941a049a44a3e86
+DIST bytelist-1.0.10.tar.gz 15619 BLAKE2B d715949e9d78201c2fbc97a6c055630b83db4989108f7fb5f68d09cc461b4bf8f30f7ffb0ad66166aa13f23a50a832e12d721ffa2a72206348db0f4070fad941 SHA512 fb522a43d5cac8a4804f64caa38fb9ab793a0f0688a69987f3be6f2245a4a2c9739a0d807f88be947c0bd7f908c069a2f8092cc4d5314c3fddb6541d9db70f7c
+EBUILD bytelist-1.0.10.ebuild 988 BLAKE2B 1fd8bafad0f950e3f53c39be7b12889304725c05350548e17ad1870f825e391d62cb4dfaa86b01706bc886031661074dcbe6808fc02f1056421c9a9e8847c834 SHA512 a3c74bbc0603a0fac3c821ae07ca5b75233914e5da67f3a0a4013e2d5a49bd6501e79b03e5325dd2e4214f82e737171668a35cd9525c5ea0811c7c79de9ba59e
+MISC metadata.xml 303 BLAKE2B eb9bfc2199bfcb29a93a127137edd0d330f868824bccf1c74830515f1f3c4f5d008d9ab6a7e5c4f9f87fed1ef7e954b7955d6c70e1e840b400428920080be362 SHA512 94ee8b7bd5d0b719b1f2afd8b3f61812bb73cd764b482bcaa73a3d60ee8080b44486697fd58dc601f23502893a0995e1a46dfb262e7c9793531765eceeb1051f
diff --git a/dev-java/bytelist/bytelist-1.0.10.ebuild b/dev-java/bytelist/bytelist-1.0.10.ebuild
new file mode 100644
index 000000000000..eb1aa2d3d034
--- /dev/null
+++ b/dev-java/bytelist/bytelist-1.0.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="JRuby support library"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://github.com/jruby/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEP="dev-java/jcodings:0"
+
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.5"
+
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.5
+ test? ( dev-java/ant-junit:0 )"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}"/jruby-${PN}-* "${WORKDIR}"/${P} || die
+}
+
+java_prepare() {
+ cp "${FILESDIR}"/maven-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_GENTOO_CLASSPATH="jcodings"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/bytelist/files/maven-build.xml b/dev-java/bytelist/files/maven-build.xml
new file mode 100644
index 000000000000..ee880775a409
--- /dev/null
+++ b/dev-java/bytelist/files/maven-build.xml
@@ -0,0 +1,219 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<project name="bytelist-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="bytelist"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="test"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ manifest="MANIFEST.MF"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ </target>
+
+</project>
diff --git a/dev-java/bytelist/metadata.xml b/dev-java/bytelist/metadata.xml
new file mode 100644
index 000000000000..96cb48b87e21
--- /dev/null
+++ b/dev-java/bytelist/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jruby/bytelist</remote-id>
+ </upstream>
+</pkgmetadata>