summaryrefslogtreecommitdiff
path: root/dev-java/bcprov/bcprov-1.50-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/bcprov/bcprov-1.50-r2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/bcprov/bcprov-1.50-r2.ebuild')
-rw-r--r--dev-java/bcprov/bcprov-1.50-r2.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-java/bcprov/bcprov-1.50-r2.ebuild b/dev-java/bcprov/bcprov-1.50-r2.ebuild
deleted file mode 100644
index 1eba489d573b..000000000000
--- a/dev-java/bcprov/bcprov-1.50-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_P="${PN}-jdk15on-${PV/./}"
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="1.50"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-CDEPEND=""
-
-DEPEND=">=virtual/jdk-1.6
- app-arch/unzip
- ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-JAVA_ENCODING="ISO-8859-1"
-
-# Package can't be built with test as bcprov and bcpkix can't be built with test.
-RESTRICT="test"
-
-src_unpack() {
- default
- cd "${S}"
- unpack ./src.zip
-}
-
-java_prepare() {
- if ! use test; then
- # There are too many files to delete so we won't be using JAVA_RM_FILES
- # (it produces a lot of output).
- local RM_TEST_FILES=()
- while read -d $'\0' -r file; do
- RM_TEST_FILES+=("${file}")
- done < <(find . -name "*Test*.java" -type f -print0)
- while read -d $'\0' -r file; do
- RM_TEST_FILES+=("${file}")
- done < <(find . -name "*Mock*.java" -type f -print0)
-
- rm -v "${RM_TEST_FILES[@]}"
- fi
-}
-
-src_compile() {
- java-pkg-simple_src_compile
-}
-
-src_install() {
- java-pkg-simple_src_install
- use source && java-pkg_dosrc org
-}