summaryrefslogtreecommitdiff
path: root/dev-java/asm-commons/asm-commons-6.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-java/asm-commons/asm-commons-6.2.1.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-java/asm-commons/asm-commons-6.2.1.ebuild')
-rw-r--r--dev-java/asm-commons/asm-commons-6.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/asm-commons/asm-commons-6.2.1.ebuild b/dev-java/asm-commons/asm-commons-6.2.1.ebuild
new file mode 100644
index 000000000000..47ceb6a135cd
--- /dev/null
+++ b/dev-java/asm-commons/asm-commons-6.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bytecode manipulation framework for Java (Common class adaptors)"
+HOMEPAGE="http://asm.ow2.org"
+MY_P="ASM_${PV//./_}"
+SRC_URI="https://gitlab.ow2.org/asm/asm/-/archive/${MY_P}/asm-${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT=`ver_cut 1`
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+RESTRICT="test"
+
+CDEPEND="dev-java/asm-analysis:${SLOT} dev-java/asm-tree:${SLOT} dev-java/asm:${SLOT}"
+DEPEND=">=virtual/jdk-1.8
+${CDEPEND}
+"
+RDEPEND=">=virtual/jre-1.8
+${CDEPEND}
+"
+
+JAVA_GENTOO_CLASSPATH="asm-${SLOT} asm-tree-${SLOT} asm-analysis-${SLOT}"
+JAVA_SRC_DIR="asm-${MY_P}/${PN}/src/main/java"