summaryrefslogtreecommitdiff
path: root/dev-java/aqute-bnd-annotation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /dev-java/aqute-bnd-annotation
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'dev-java/aqute-bnd-annotation')
-rw-r--r--dev-java/aqute-bnd-annotation/Manifest3
-rw-r--r--dev-java/aqute-bnd-annotation/aqute-bnd-annotation-6.3.1.ebuild48
-rw-r--r--dev-java/aqute-bnd-annotation/metadata.xml7
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/aqute-bnd-annotation/Manifest b/dev-java/aqute-bnd-annotation/Manifest
new file mode 100644
index 000000000000..fea6d18d37ef
--- /dev/null
+++ b/dev-java/aqute-bnd-annotation/Manifest
@@ -0,0 +1,3 @@
+DIST biz.aQute.bnd.annotation-6.3.1-sources.jar 50600 BLAKE2B 6ace86a803c378be17b4ecfb658eb17e9c95f4f8797cdf22cbb9a5acb2a382fe0ee6791ad0280a2de9d9e85fbe2732487e693b2c93f08145b3633810f480f8b9 SHA512 751855a173e6d5f9d09f6d63775b97d971cebbfc019053988ec7fe144d0f49b4d09b9a2339d63bb43cea51d09d7d766554255f727cad8d73d9c196097e58d0fd
+EBUILD aqute-bnd-annotation-6.3.1.ebuild 1616 BLAKE2B a72e705175ffa59add0e5e847924989c1e5ac614e4d04b4489f41bcef7ddafff95980c37e4883e6c0b25cc16cf1c6e51253dc2f5a420f7543f31786337f5516d SHA512 4561f5e8ab5796fa0bfb92ce03fe0b9e43ba6018b5a164feb0f3afd2cf2ca71bf4bd7087938b185b1ab87e8eba3346854ef8406a04df5c734ed90eb96e3de2e7
+MISC metadata.xml 217 BLAKE2B cb41a7bd7e5c55319465d67551eae75371cc72d58629c61f70a7f54c388645d5ab1427c66dfdd5954e36ca40f0d3209f871d476cacd61516dd57e3297aaa601f SHA512 4df8395dcf07c52adadee71ad7dfa9f611ade8485cc9869397d0037272ae9add9b40d90669da8b80e578b4ee14c512da01ba096abe39a5859ac71c5316e425b6
diff --git a/dev-java/aqute-bnd-annotation/aqute-bnd-annotation-6.3.1.ebuild b/dev-java/aqute-bnd-annotation/aqute-bnd-annotation-6.3.1.ebuild
new file mode 100644
index 000000000000..c8d4fe406d41
--- /dev/null
+++ b/dev-java/aqute-bnd-annotation/aqute-bnd-annotation-6.3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom biz.aQute.bnd.annotation-6.3.1.pom --download-uri https://repo1.maven.org/maven2/biz/aQute/bnd/biz.aQute.bnd.annotation/6.3.1/biz.aQute.bnd.annotation-6.3.1-sources.jar --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild aqute-bnd-annotation-6.3.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="biz.aQute.bnd:biz.aQute.bnd.annotation:6.3.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="bnd Annotations Library"
+HOMEPAGE="https://bnd.bndtools.org/"
+SRC_URI="https://repo1.maven.org/maven2/biz/aQute/bnd/biz.aQute.bnd.annotation/${PV}/biz.aQute.bnd.annotation-${PV}-sources.jar"
+
+LICENSE="Apache-2.0 EPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+# Common dependencies
+# POM: biz.aQute.bnd.annotation-${PV}.pom
+# org.osgi:org.osgi.resource:1.0.0 -> !!!artifactId-not-found!!!
+# org.osgi:org.osgi.service.serviceloader:1.0.0 -> !!!artifactId-not-found!!!
+
+CP_DEPEND="dev-java/osgi-annotation:0"
+
+# Compile dependencies
+# POM: biz.aQute.bnd.annotation-${PV}.pom
+# org.osgi:org.osgi.namespace.extender:1.0.1 -> !!!artifactId-not-found!!!
+# org.osgi:org.osgi.namespace.service:1.0.0 -> !!!artifactId-not-found!!!
+# org.osgi:osgi.annotation:8.1.0 -> >=dev-java/osgi-annotation-8.1.0:0
+
+DEPEND=">=virtual/jdk-1.8:*
+ dev-java/osgi-cmpn:8
+ dev-java/osgi-core:0
+ ${CP_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.8:*
+ ${CP_DEPEND}"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+JAVA_CLASSPATH_EXTRA="osgi-cmpn-8,osgi-core"
+JAVA_SRC_DIR="."
diff --git a/dev-java/aqute-bnd-annotation/metadata.xml b/dev-java/aqute-bnd-annotation/metadata.xml
new file mode 100644
index 000000000000..75321cfb5598
--- /dev/null
+++ b/dev-java/aqute-bnd-annotation/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>