summaryrefslogtreecommitdiff
path: root/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild')
-rw-r--r--dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild b/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
new file mode 100644
index 000000000000..31d041e6a974
--- /dev/null
+++ b/dev-java/antlr-runtime/antlr-runtime-4.9.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Without annotation processing using runtime-testsuite/processors,
+# the tests are bound to fail. However, the annotation processor
+# has been dropped from the 'master' branch as of January 2022, so
+# when updating this package to a new upstream version, please
+# check if it is possible to enable the tests and pass them.
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.antlr:antlr4-runtime:4.9.3"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN%-runtime}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ANTLR 4 Runtime"
+HOMEPAGE="https://www.antlr.org/"
+SRC_URI="https://github.com/antlr/antlr4/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="4"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+S="${WORKDIR}/${MY_PN}4-${PV}"
+
+JAVA_SRC_DIR="runtime/Java/src"