summaryrefslogtreecommitdiff
path: root/dev-java/ant-trax/ant-trax-1.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/ant-trax/ant-trax-1.9.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/ant-trax/ant-trax-1.9.2.ebuild')
-rw-r--r--dev-java/ant-trax/ant-trax-1.9.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/ant-trax/ant-trax-1.9.2.ebuild b/dev-java/ant-trax/ant-trax-1.9.2.ebuild
new file mode 100644
index 000000000000..ea41617835ec
--- /dev/null
+++ b/dev-java/ant-trax/ant-trax-1.9.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+ANT_TASK_DEPNAME=""
+ANT_TASK_DISABLE_VM_DEPS="true"
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant .jar with optional tasks depending on XML transformer (Deprecated!)"
+KEYWORDS="amd64 ~arm ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Dependency needed for jar.
+DEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ # The classes were moved to ant-core in 1.8.1, this is just for compatibility.
+ mkdir -p build/lib/empty && cd build/lib/empty || die
+ jar -cf ../${PN}.jar .
+}
+
+pkg_postinst() {
+ elog "Upstream has removed ant-trax.jar as of 1.8.1 and moved the classes to ant.jar"
+ elog "This package thus installs an empty jar for compatibility"
+ elog "and will be removed once reverse dependencies are transitioned."
+}