summaryrefslogtreecommitdiff
path: root/dev-java/ant-testutil/ant-testutil-1.10.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
commit2e34d110f164bf74d55fced27fe0000201b3eec5 (patch)
treef00ae60197c58f84ad51f60b210738d9b70f555b /dev-java/ant-testutil/ant-testutil-1.10.9.ebuild
parentf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (diff)
gentoo resync : 01.10.2020
Diffstat (limited to 'dev-java/ant-testutil/ant-testutil-1.10.9.ebuild')
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.10.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/ant-testutil/ant-testutil-1.10.9.ebuild b/dev-java/ant-testutil/ant-testutil-1.10.9.ebuild
new file mode 100644
index 000000000000..e8763ba32556
--- /dev/null
+++ b/dev-java/ant-testutil/ant-testutil-1.10.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ANT_TASK_JDKVER=1.8
+ANT_TASK_JREVER=1.8
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional test utility classes"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+CDEPEND="dev-java/ant-core:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8
+ >=dev-java/junit-4.11:4
+ ~dev-java/ant-swing-${PV}
+ ~dev-java/ant-junit4-${PV}
+ ~dev-java/ant-junitlauncher-${PV}"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8"
+
+# The build system builds much more than it actually packages, so there are many
+# build-only deps, but since those are quite common, it wasn't worth to patch it.
+
+src_unpack() {
+ ant-tasks_src_unpack base
+ java-pkg_jar-from --build-only junit-4,ant-junit4,ant-junitlauncher,ant-swing
+ java-pkg_jar-from --build-only ant-core ant-launcher.jar
+}
+
+src_compile() {
+ eant test-jar
+}