summaryrefslogtreecommitdiff
path: root/dev-java/ant-testutil/ant-testutil-1.10.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-java/ant-testutil/ant-testutil-1.10.8.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-java/ant-testutil/ant-testutil-1.10.8.ebuild')
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.10.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/ant-testutil/ant-testutil-1.10.8.ebuild b/dev-java/ant-testutil/ant-testutil-1.10.8.ebuild
new file mode 100644
index 000000000000..dce4d1840353
--- /dev/null
+++ b/dev-java/ant-testutil/ant-testutil-1.10.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ANT_TASK_JDKVER=1.8
+ANT_TASK_JREVER=1.8
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional test utility classes"
+KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+CDEPEND="dev-java/ant-core:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8
+ >=dev-java/junit-4.11:4
+ ~dev-java/ant-swing-${PV}
+ ~dev-java/ant-junit4-${PV}
+ ~dev-java/ant-junitlauncher-${PV}"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8"
+
+# The build system builds much more than it actually packages, so there are many
+# build-only deps, but since those are quite common, it wasn't worth to patch it.
+
+src_unpack() {
+ ant-tasks_src_unpack base
+ java-pkg_jar-from --build-only junit-4,ant-junit4,ant-junitlauncher,ant-swing
+ java-pkg_jar-from --build-only ant-core ant-launcher.jar
+}
+
+src_compile() {
+ eant test-jar
+}