summaryrefslogtreecommitdiff
path: root/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild')
-rw-r--r--dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild b/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild
new file mode 100644
index 000000000000..67438bbc6ba1
--- /dev/null
+++ b/dev-haskell/yesod-auth-hashdb/yesod-auth-hashdb-1.7.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication plugin for Yesod"
+HOMEPAGE="https://github.com/paul-rouse/yesod-auth-hashdb"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.11:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/yesod-auth-1.4.18:=[profile?] <dev-haskell/yesod-auth-1.7:=[profile?]
+ >=dev-haskell/yesod-core-1.4.19:=[profile?] <dev-haskell/yesod-core-1.7:=[profile?]
+ >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.7:=[profile?]
+ >=dev-haskell/yesod-persistent-1.2:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( dev-haskell/basic-prelude
+ >=dev-haskell/hspec-2.0.0
+ dev-haskell/http-conduit
+ dev-haskell/http-types
+ dev-haskell/monad-logger
+ dev-haskell/network-uri
+ dev-haskell/persistent-sqlite
+ dev-haskell/resourcet
+ dev-haskell/unordered-containers
+ dev-haskell/wai-extra
+ dev-haskell/yesod
+ >=dev-haskell/yesod-test-1.5.0.1
+ || ( ( >=dev-haskell/yesod-auth-1.4.18 <dev-haskell/yesod-auth-1.5 )
+ ( >=dev-haskell/yesod-auth-1.6.1 <dev-haskell/yesod-auth-1.7 ) ) )
+"