summaryrefslogtreecommitdiff
path: root/dev-haskell/yaml/yaml-0.8.17.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/yaml/yaml-0.8.17.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/yaml/yaml-0.8.17.1.ebuild')
-rw-r--r--dev-haskell/yaml/yaml-0.8.17.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/yaml/yaml-0.8.17.1.ebuild b/dev-haskell/yaml/yaml-0.8.17.1.ebuild
new file mode 100644
index 000000000000..1fac24fc45c1
--- /dev/null
+++ b/dev-haskell/yaml/yaml-0.8.17.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for parsing and rendering YAML documents"
+HOMEPAGE="https://github.com/snoyberg/yaml/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+no-examples no-exe no-unicode system-libyaml"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/attoparsec-0.11.3.0:=[profile?]
+ >=dev-haskell/conduit-1.1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/enclosed-exceptions:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/semigroups:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.1:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ !no-examples? ( dev-haskell/raw-strings-qq:=[profile?] )
+ system-libyaml? ( dev-libs/libyaml )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/aeson-qq
+ dev-haskell/base-compat
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ dev-haskell/mockery )
+ system-libyaml? ( virtual/pkgconfig )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag no-examples no-examples) \
+ $(cabal_flag no-exe no-exe) \
+ $(cabal_flag no-unicode no-unicode) \
+ $(cabal_flag system-libyaml system-libyaml)
+}