summaryrefslogtreecommitdiff
path: root/dev-haskell/wxc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/wxc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/wxc')
-rw-r--r--dev-haskell/wxc/Manifest3
-rw-r--r--dev-haskell/wxc/metadata.xml18
-rw-r--r--dev-haskell/wxc/wxc-0.92.2.0.ebuild57
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-haskell/wxc/Manifest b/dev-haskell/wxc/Manifest
new file mode 100644
index 000000000000..a0d86e323b47
--- /dev/null
+++ b/dev-haskell/wxc/Manifest
@@ -0,0 +1,3 @@
+DIST wxc-0.92.2.0.tar.gz 203065 BLAKE2B 3f873b3bbc50e5fa7690f2f05a25ab360260d90523dd0b9c016f5dfeea99e9a59fe4848de520d642d2cea52dbadfd69aa31671f521243240488d643d4554e880 SHA512 e6fba1be94978603965b8902fad9326772b5483d5df621d5245f1fae97d85bcb1aff4565f1e8396de23c854050151c5e009e34a1ea29c3037057599ac0412bcd
+EBUILD wxc-0.92.2.0.ebuild 1671 BLAKE2B 4f7a1e5a1e182fb00c7882bfba1ba44be7e0306c2aa1592b850d9141b56eea5014430eb2db97345564e1f56650df7e9b4dca52ae4b893cf6889eb520c6c8e9e6 SHA512 5aa427edcc824b7856a8926da4e131e9406b891fb2cf038c59ad9216fc054e84e970d86f7deb4d7f3907096bc6413b84b6ecc2e2f05b61979a1d1697af7db93e
+MISC metadata.xml 796 BLAKE2B 3cb8acb5020436e15b3310fb974d1707af624d9a01aa64d66550bd64d17906870aadd01ecaa90bfe04b02564db169688c2774bd62df48501544467461cb333b3 SHA512 47ffc15e1167354eebbbeecfe9557d01dc832a67c2b7d213528f8be73846dab272351670f5b45be9098713c4ec3106753d8fa1cffdbb2844d0a9d8cd3146cd94
diff --git a/dev-haskell/wxc/metadata.xml b/dev-haskell/wxc/metadata.xml
new file mode 100644
index 000000000000..7960f5bec78c
--- /dev/null
+++ b/dev-haskell/wxc/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ wxHaskell is a portable and native GUI library for Haskell. It is
+ built on top of wxWidgets, a comprehensive C++ library that is
+ portable across all major GUI platforms, including GTK, Windows,
+ X11, and MacOS X. This version works with wxWidgets 2.9 only.
+ Distributed under the WXWINDOWS LIBRARY LICENSE. Please see
+ LICENSE file, but note that this is essentially LGPL with an
+ exception allowing binary distribution of proprietary software.
+ This is the same license as wxWidgets itself uses.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/wxc/wxc-0.92.2.0.ebuild b/dev-haskell/wxc/wxc-0.92.2.0.ebuild
new file mode 100644
index 000000000000..5d2fefd68d98
--- /dev/null
+++ b/dev-haskell/wxc/wxc-0.92.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+WX_GTK_VER="3.0"
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal multilib versionator wxwidgets
+
+DESCRIPTION="wxHaskell C++ wrapper"
+HOMEPAGE="https://wiki.haskell.org/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">dev-haskell/split-0:=[profile?]
+ >=dev-haskell/wxdirect-0.90.1.1:${WX_GTK_VER}=[profile?]
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,gstreamer,opengl]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"
+
+src_prepare() {
+ sed -e "s@\"wx-config\"@\"${WX_CONFIG}\"@g" \
+ -i "${S}/Setup.hs" || die "Could not specify wx-config in Setup.hs"
+}
+
+src_configure() {
+ local cgcc=()
+ for i in ${CXXFLAGS}
+ do
+ cgcc+=( --gcc-option="${i}" )
+ done
+ # Trying to specify the LDFLAGS in --ld-option does not work, as ld does
+ # not understand ld options prefixed with -Wl,
+ # The linker that is used to link the libwxc.so shared library is hard coded
+ # in Setup.hs. So the --with-ld would not change the linker used when
+ # linking libwxc.so. --with-ld="gcc" does not help, as then cabal passes
+ # ld options like -x to gcc which then returns a non-zero exit status, then
+ # cabal ignores all the --ld-option parameters.
+ # So I place all the LDFLAGS in --gcc-option parameters. They are ignored
+ # when building .o files.
+ local cld=()
+ for i in ${LDFLAGS}
+ do
+ cld+=( --gcc-option="${i}" )
+ done
+ cabal_src_configure ${cgcc[*]} ${cld[*]} --verbose=3
+}