summaryrefslogtreecommitdiff
path: root/dev-haskell/wx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/wx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/wx')
-rw-r--r--dev-haskell/wx/Manifest3
-rw-r--r--dev-haskell/wx/metadata.xml11
-rw-r--r--dev-haskell/wx/wx-0.92.2.0.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/wx/Manifest b/dev-haskell/wx/Manifest
new file mode 100644
index 000000000000..76bd00f02c55
--- /dev/null
+++ b/dev-haskell/wx/Manifest
@@ -0,0 +1,3 @@
+DIST wx-0.92.2.0.tar.gz 50938 BLAKE2B 3a1b8c4391c73c78d8aa635e48ebd135671bbec4c5312de715966f6596e2201c50c8284c69fd8f873c65e72a654944374c757de4e8c4afe81939e9771a318d77 SHA512 f8bbb2598fc1555030ebe3084737d6f8c0691a3e2fddd9b979c4694442b458937a9bb6afe347b2a5661b7d70339194087ce083ad6efc01173bc0f62b72bf1134
+EBUILD wx-0.92.2.0.ebuild 965 BLAKE2B 2d3415e2b464ce8a373ff0cd31678ec557742c50ac87b130128b3e6452f69f525bf053dbd11d5345db9fb69606290b711fd312b6d67f029980e0b8fc6286011b SHA512 7a17efc64386b73494357ea5ccb84a08fa700b23ec61a216126d86ffa38a2ffd5a7633ca513825238243469972b18077f13e6103d3f746a285f33add9128d9f9
+MISC metadata.xml 549 BLAKE2B 7645a80403b4176584de8783c6bbf36df125a59aeb27867d88e048d35de11f8f69df2b80a88ceeefdc200156c81a5b3d0db8288a2afb0e2c7219efd5eced2fb9 SHA512 5914f30a0be778084cb801fc3521cf85490a67b9f5a0ee1c5cadb9bd44441c8d1a1840275944d8d1deee334289fd86b7b71bb4b4ab73700e25333f2658ce0d26
diff --git a/dev-haskell/wx/metadata.xml b/dev-haskell/wx/metadata.xml
new file mode 100644
index 000000000000..89beeeef44de
--- /dev/null
+++ b/dev-haskell/wx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ wxHaskell is a portable and native GUI library for Haskell. It is built on top of wxWidgets - a comprehensive C++ library that is portable across all major GUI platforms; including GTK, Windows, X11, and MacOS X. This version works with wxWidgets 2.8 only.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/wx/wx-0.92.2.0.ebuild b/dev-haskell/wx/wx-0.92.2.0.ebuild
new file mode 100644
index 000000000000..817a3f70513e
--- /dev/null
+++ b/dev-haskell/wx/wx-0.92.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+WX_GTK_VER="3.0"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="wxHaskell"
+HOMEPAGE="https://wiki.haskell.org/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxcore-0.92:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"
+
+src_configure() {
+ # ghc DCE bug: https://ghc.haskell.org/trac/ghc/ticket/9155
+ [[ $(ghc-version) == 7.8.2 ]] && replace-hcflags -O[2-9] -O1
+ # ghc DCE bug: https://ghc.haskell.org/trac/ghc/ticket/9303
+ [[ $(ghc-version) == 7.8.3 ]] && replace-hcflags -O[2-9] -O1
+
+ haskell-cabal_src_configure \
+ --flag=newbase
+}