summaryrefslogtreecommitdiff
path: root/dev-haskell/wreq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/wreq
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/wreq')
-rw-r--r--dev-haskell/wreq/Manifest3
-rw-r--r--dev-haskell/wreq/metadata.xml39
-rw-r--r--dev-haskell/wreq/wreq-0.5.3.2.ebuild76
3 files changed, 118 insertions, 0 deletions
diff --git a/dev-haskell/wreq/Manifest b/dev-haskell/wreq/Manifest
new file mode 100644
index 000000000000..a44824769ca0
--- /dev/null
+++ b/dev-haskell/wreq/Manifest
@@ -0,0 +1,3 @@
+DIST wreq-0.5.3.2.tar.gz 57521 BLAKE2B 2265e7f8abe371371d079f735d61917c0efa5b78e2d3e8965e3b720a94e89b3a7ae05824f54d6fe765c643ed81f506b12694355b0bf1d7b4c2e9198d08c2317c SHA512 5a2c62b973758cb8ce2bf20504e328090896fa25e7ee1f77b472d7cf5156e08b6d85bf4341ff45e44db1724070fcf3c0f21037fa0a79211a1767024328f7c779
+EBUILD wreq-0.5.3.2.ebuild 2342 BLAKE2B 7aacbea34d850f4123674c4b325232c5ef2a5e16556de9aee0fd5b972ef7b1727457209523a4cf9db17dd5db8fa55c8022f9c18d83665dabf913f0b5c0d3920b SHA512 e60a8c4306b5c68e69ec417017d3f84b899e50297988ad3ea35c7c40d02252f3696c72c278b8dd0fa1e0a04c1c0fdd09f055412f0a3595a9b4003f8145fd22d3
+MISC metadata.xml 1054 BLAKE2B cddcf6bf00139c602bcca861bd8dc3a6d7b625e3e9809d4155206c84fecdfb2e782919a97fdffe1fa96db8643f034b5f7861777a4a39477adfdd25223ffb5459 SHA512 46661292b5a750539ef4a08a30fc32b72782de57b70e59f1f9294400cf6d872b625fb58151f23ee5ca1638b1ed0ac1bf6e1d0ea8053817d5a204b7107ea4ac88
diff --git a/dev-haskell/wreq/metadata.xml b/dev-haskell/wreq/metadata.xml
new file mode 100644
index 000000000000..887b9ecf25d1
--- /dev/null
+++ b/dev-haskell/wreq/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+
+ A web client library that is designed for ease of use.
+
+ Tutorial: &lt;http://www.serpentine.com/wreq/tutorial.html&gt;
+
+ Features include:
+
+ * Simple but powerful `lens`-based API
+
+ * A solid test suite, and built on reliable libraries like
+ http-client and lens
+
+ * Session handling includes connection keep-alive and pooling, and
+ cookie persistence
+
+ * Automatic response body decompression
+
+ * Powerful multipart form and file upload handling
+
+ * Support for JSON requests and responses, including navigation of
+ schema-less responses
+
+ * Basic and OAuth2 bearer authentication
+
+ * Early TLS support via the tls package
+ </longdescription>
+ <use>
+ <flag name="aws">Enable AWS tests</flag>
+ <flag name="httpbin">Install client</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-haskell/wreq/wreq-0.5.3.2.ebuild b/dev-haskell/wreq/wreq-0.5.3.2.ebuild
new file mode 100644
index 000000000000..62ccd4251442
--- /dev/null
+++ b/dev-haskell/wreq/wreq-0.5.3.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+#hackport: flags: -developer,+doctest
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An easy-to-use HTTP client library"
+HOMEPAGE="http://www.serpentine.com/wreq"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="aws httpbin"
+
+RESTRICT=test # needs network
+
+RDEPEND=">=dev-haskell/aeson-1.0.0.0:=[profile?]
+ >=dev-haskell/attoparsec-0.11.1.0:=[profile?]
+ >=dev-haskell/authenticate-oauth-1.5:=[profile?]
+ dev-haskell/base16-bytestring:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ >=dev-haskell/exceptions-0.5:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ >=dev-haskell/http-client-0.6:=[profile?]
+ >=dev-haskell/http-client-tls-0.3.3:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/lens-4.5:=[profile?]
+ dev-haskell/lens-aeson:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ >=dev-haskell/psqueues-0.2:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/time-locale-compat:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ httpbin? ( >=dev-haskell/aeson-pretty-0.8.0:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/snap-core-1.0.0.0:=[profile?]
+ >=dev-haskell/snap-server-0.9.4.4:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ dev-haskell/uuid:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ >=dev-haskell/cabal-doctest-1.0.2 <dev-haskell/cabal-doctest-1.1
+ test? ( dev-haskell/doctest
+ dev-haskell/hunit
+ dev-haskell/network-info
+ >=dev-haskell/quickcheck-2.7
+ dev-haskell/temporary
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/vector
+ !httpbin? ( >=dev-haskell/aeson-pretty-0.8.0
+ dev-haskell/base64-bytestring
+ >=dev-haskell/snap-core-1.0.0.0
+ >=dev-haskell/snap-server-0.9.4.4
+ dev-haskell/unix-compat
+ dev-haskell/uuid ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag aws aws) \
+ --flag=-developer \
+ --flag=doctest \
+ $(cabal_flag httpbin httpbin)
+}