summaryrefslogtreecommitdiff
path: root/dev-haskell/warp-tls/warp-tls-3.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/warp-tls/warp-tls-3.2.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/warp-tls/warp-tls-3.2.3.ebuild')
-rw-r--r--dev-haskell/warp-tls/warp-tls-3.2.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/warp-tls/warp-tls-3.2.3.ebuild b/dev-haskell/warp-tls/warp-tls-3.2.3.ebuild
new file mode 100644
index 000000000000..c0950962a8b4
--- /dev/null
+++ b/dev-haskell/warp-tls/warp-tls-3.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: +tls_1_1_3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP over TLS support for Warp via the TLS package"
+HOMEPAGE="https://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cryptonite-0.12:=[profile?]
+ >=dev-haskell/data-default-class-0.0.1:=[profile?]
+ >=dev-haskell/network-2.2.1:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ >=dev-haskell/tls-1.3.5:=[profile?]
+ >=dev-haskell/wai-3.2:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ >=dev-haskell/warp-3.2.10:=[profile?] <dev-haskell/warp-3.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=tls_1_1_3
+}