summaryrefslogtreecommitdiff
path: root/dev-haskell/wai-app-static/wai-app-static-3.1.7.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /dev-haskell/wai-app-static/wai-app-static-3.1.7.2-r1.ebuild
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'dev-haskell/wai-app-static/wai-app-static-3.1.7.2-r1.ebuild')
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-3.1.7.2-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-haskell/wai-app-static/wai-app-static-3.1.7.2-r1.ebuild b/dev-haskell/wai-app-static/wai-app-static-3.1.7.2-r1.ebuild
new file mode 100644
index 000000000000..d29aea060d12
--- /dev/null
+++ b/dev-haskell/wai-app-static/wai-app-static-3.1.7.2-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="WAI application for static serving"
+HOMEPAGE="https://www.yesodweb.com/book/web-application-interface"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="print"
+
+RDEPEND=">=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ >=dev-haskell/cryptonite-0.6:=[profile?]
+ >=dev-haskell/file-embed-0.0.3.1:=[profile?]
+ dev-haskell/http-date:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/memory-0.7:=[profile?]
+ >=dev-haskell/mime-types-0.1:=[profile?] <dev-haskell/mime-types-0.2:=[profile?]
+ >=dev-haskell/old-locale-1.0.0.2:=[profile?]
+ >=dev-haskell/optparse-applicative-0.7:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ >=dev-haskell/wai-extra-3.0:=[profile?] <dev-haskell/wai-extra-3.2:=[profile?]
+ >=dev-haskell/warp-3.0.11:=[profile?] <dev-haskell/warp-3.4:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/mockery
+ dev-haskell/network
+ dev-haskell/temporary )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'wai-extra >= 3.0 && < 3.1' 'wai-extra >= 3.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag print print)
+}