summaryrefslogtreecommitdiff
path: root/dev-haskell/vector-instances/vector-instances-3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/vector-instances/vector-instances-3.4.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/vector-instances/vector-instances-3.4.ebuild')
-rw-r--r--dev-haskell/vector-instances/vector-instances-3.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/vector-instances/vector-instances-3.4.ebuild b/dev-haskell/vector-instances/vector-instances-3.4.ebuild
new file mode 100644
index 000000000000..80286959a696
--- /dev/null
+++ b/dev-haskell/vector-instances/vector-instances-3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Orphan Instances for 'Data.Vector'"
+HOMEPAGE="https://github.com/ekmett/vector-instances"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+hashable"
+
+RDEPEND=">=dev-haskell/comonad-3:=[profile?]
+ >=dev-haskell/keys-3:=[profile?]
+ >=dev-haskell/pointed-3:=[profile?]
+ >=dev-haskell/semigroupoids-3:=[profile?]
+ >=dev-haskell/semigroups-0.8.3.1:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ hashable? ( >=dev-haskell/hashable-1.1.1.0:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag hashable hashable)
+}