summaryrefslogtreecommitdiff
path: root/dev-haskell/unix-compat/unix-compat-0.4.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/unix-compat/unix-compat-0.4.1.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/unix-compat/unix-compat-0.4.1.4.ebuild')
-rw-r--r--dev-haskell/unix-compat/unix-compat-0.4.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-haskell/unix-compat/unix-compat-0.4.1.4.ebuild b/dev-haskell/unix-compat/unix-compat-0.4.1.4.ebuild
new file mode 100644
index 000000000000..a71171f6d636
--- /dev/null
+++ b/dev-haskell/unix-compat/unix-compat-0.4.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Portable POSIX-compatibility layer"
+HOMEPAGE="https://github.com/jystic/unix-compat"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="old-time"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag old-time old-time)
+}