summaryrefslogtreecommitdiff
path: root/dev-haskell/unexceptionalio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/unexceptionalio
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/unexceptionalio')
-rw-r--r--dev-haskell/unexceptionalio/Manifest3
-rw-r--r--dev-haskell/unexceptionalio/metadata.xml20
-rw-r--r--dev-haskell/unexceptionalio/unexceptionalio-0.3.0.ebuild24
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/unexceptionalio/Manifest b/dev-haskell/unexceptionalio/Manifest
new file mode 100644
index 000000000000..c240c4c82dbc
--- /dev/null
+++ b/dev-haskell/unexceptionalio/Manifest
@@ -0,0 +1,3 @@
+DIST unexceptionalio-0.3.0.tar.gz 2335 BLAKE2B e2d3a7f63dece9631bcbe602d2f8c06b151d103f85ad3bb84de869b3194f20e2f8483523f15a828a8526af856fce53d7fa6f669c2a659c957b7ccca10466c878 SHA512 be6479cfdb39707473e07639b3a35c4e178571ec2b45a356e278c9bb20710775fe26c086239aa65c2d5f201730df223b5ca3e42ea61e1ffb9a285f384e62f4b6
+EBUILD unexceptionalio-0.3.0.ebuild 565 BLAKE2B 2f6f3269e8212b5de75506da5187bbfb00d05f74a24dd0aecf73c875dfe6f709298aacd24ddc3933ac62341db3342e115e42d4d0661cffda3d66b97533b962b7 SHA512 3d95cda056b7658d641fbd55ae39643025c23a3f7825063daa8d5e25558bde72a299cac54839c4be3976d8b84d858198fe66c939537bae723a8530b94c4f78d4
+MISC metadata.xml 636 BLAKE2B a45a7539e3dca76bfe3b5dcc7e3dd5bc36b55f9d0357f02cbb726f4b6c6a38d4845cacf62ad27c40136850fb9102ce96e64cdacf750577d87fbb76f0559d91b7 SHA512 04828cdccb54886eeec3e13425a91b2f3924a7758428a4adc9db513e5a6475a635026f4540c23ba1f739dd821f7ea8bd75a25c823a14d724648b47f0cccb67fb
diff --git a/dev-haskell/unexceptionalio/metadata.xml b/dev-haskell/unexceptionalio/metadata.xml
new file mode 100644
index 000000000000..7e8b34c0ddcc
--- /dev/null
+++ b/dev-haskell/unexceptionalio/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ When you've caught all the exceptions that can be handled safely,
+ this is what you're left with.
+
+ It is intended that you use qualified imports with this library.
+
+ &gt; import UnexceptionalIO (UIO)
+ &gt; import qualified UnexceptionalIO as UIO
+ </longdescription>
+ <upstream>
+ <remote-id type="github">singpolyma/unexceptionalio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/unexceptionalio/unexceptionalio-0.3.0.ebuild b/dev-haskell/unexceptionalio/unexceptionalio-0.3.0.ebuild
new file mode 100644
index 000000000000..bdb5e4de104c
--- /dev/null
+++ b/dev-haskell/unexceptionalio/unexceptionalio-0.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="IO without any non-error, synchronous exceptions"
+HOMEPAGE="https://github.com/singpolyma/unexceptionalio"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"