summaryrefslogtreecommitdiff
path: root/dev-haskell/torrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/torrent
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/torrent')
-rw-r--r--dev-haskell/torrent/Manifest5
-rw-r--r--dev-haskell/torrent/metadata.xml11
-rw-r--r--dev-haskell/torrent/torrent-10000.0.0.ebuild27
-rw-r--r--dev-haskell/torrent/torrent-10000.0.1.ebuild26
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-haskell/torrent/Manifest b/dev-haskell/torrent/Manifest
new file mode 100644
index 000000000000..5ddf2f64f4c0
--- /dev/null
+++ b/dev-haskell/torrent/Manifest
@@ -0,0 +1,5 @@
+DIST torrent-10000.0.0.tar.gz 3549 BLAKE2B 414547b6cd8a090a8da198dd82122fcdfe87af4db59ff06f558461550ee6c041de7f69758bae184961ff8772ccbd17523a8c0fa4dc6f6729db1293da90ee1c9a SHA512 361f7ca99196278dccdf4ac20dbe5d9861fd979ea1c84786a93928cc46e51f949618e34e55342f08e19ce935a8313526c580fed6413209a6365efc306b5165d5
+DIST torrent-10000.0.1.tar.gz 3819 BLAKE2B f2a1569c697bbd732fe4f801ff797e2cea6efa69bbd08779f36d729496dd1cd6ccc0d55dd2fca40a6c07f0e1b577213a93f13a1a2b92f9b90030037af5de481e SHA512 66b69a0bb2b7dc08fb738c60bf6402ad69a5e60c6ccc1002e9d394c9faf75e49f444ed690dd3d17c1de978d1ac85ac48f03b6dda143445019c698db83dea3fcb
+EBUILD torrent-10000.0.0.ebuild 650 BLAKE2B c07024fee8b1218d0ecb397d20e55874e7f86c17a1b8feaaaf72f95fdffab8f1833cf66c6f0c5850cb678639bc96b70b536b82c8ab2215f56ba3503db11f9716 SHA512 73f2a201a269c50be88a8fa7d72356ebd5ec1ed4e72eb6512f0e566fa3d82f0cd32aeadb6a1a4bccaaca4318f2544127ad829f5f02f7d43eacdc63d0d056eace
+EBUILD torrent-10000.0.1.ebuild 618 BLAKE2B 09fb7fddfcfb1aa247bf3f245d31650737327903af7f3c7f9f9014ecad2d960e7413c6cbfeb914d149fac26492cdd7ce8ece53ac20e4da181514a75ddd5689a8 SHA512 c10650d097abb57ce7f76f98c644c6fe0adea931f39009ca0e2deeea6082b6a3380328f02c7821b597bda9390d96768f6fef766991dc7680cf8018e0ef8b93d9
+MISC metadata.xml 327 BLAKE2B 623fd681553ed644e9708f183a159ce52e453c170e002158ac27434868083dd16d6552b62d6e86aa291ce1e6bea80e9d83ba5acface8d3b7bd4b1d8b9136398e SHA512 c7b6ac893521cc21a96055dff085a186e55a6fe20a1903bf40d3af032c3e227d82a1a93efa31ff7d0a13a1f5c124acf0bbd6b1941a6ea3208b339cd0e5056556
diff --git a/dev-haskell/torrent/metadata.xml b/dev-haskell/torrent/metadata.xml
new file mode 100644
index 000000000000..93afc894883d
--- /dev/null
+++ b/dev-haskell/torrent/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ BitTorrent file parser and generater
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/torrent/torrent-10000.0.0.ebuild b/dev-haskell/torrent/torrent-10000.0.0.ebuild
new file mode 100644
index 000000000000..a15e03441d2b
--- /dev/null
+++ b/dev-haskell/torrent/torrent-10000.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="BitTorrent file parser and generater"
+HOMEPAGE="http://hackage.haskell.org/package/torrent"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/bencode-0.2:=[profile?]
+ dev-haskell/binary:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/torrent/torrent-10000.0.1.ebuild b/dev-haskell/torrent/torrent-10000.0.1.ebuild
new file mode 100644
index 000000000000..3d7a18338405
--- /dev/null
+++ b/dev-haskell/torrent/torrent-10000.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="BitTorrent file parser and generater"
+HOMEPAGE="http://hackage.haskell.org/package/torrent"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/bencode-0.2:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"