summaryrefslogtreecommitdiff
path: root/dev-haskell/top
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 02:42:13 +0100
commite7f37e03b952768321c8c943a80eff4152ea7bbd (patch)
tree355a9efb62297418cdadbc424b09dbafc54257e5 /dev-haskell/top
parent2518522472e5de9c52c78dc0246475fe0ae3cc05 (diff)
gentoo auto-resync : 22:08:2022 - 02:42:13
Diffstat (limited to 'dev-haskell/top')
-rw-r--r--dev-haskell/top/Manifest5
-rw-r--r--dev-haskell/top/files/top-1.7-ghc-7.10.patch66
-rw-r--r--dev-haskell/top/files/top-1.7-ghc84.patch12
-rw-r--r--dev-haskell/top/metadata.xml15
-rw-r--r--dev-haskell/top/top-1.7.ebuild36
5 files changed, 0 insertions, 134 deletions
diff --git a/dev-haskell/top/Manifest b/dev-haskell/top/Manifest
deleted file mode 100644
index 38ceab2281d2..000000000000
--- a/dev-haskell/top/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX top-1.7-ghc-7.10.patch 2305 BLAKE2B 13dd321a0e6f4a3fd935c650361a2c65f4ac015fefe66cee4c419e9960b98ec17738cbfc679b51bfa0e3eb10eef3809d37e3d4895b91ad22147d7d2cb6c4da9a SHA512 e5b6d8ad618787e70e06ad08e92b53c5d66dd4464a7cc476f55da86b740bf835a9e3c1e35a03dd3a390bb7798459afbdf7aed19c91491bb6d16c53092cd4a0fb
-AUX top-1.7-ghc84.patch 380 BLAKE2B 87297984a0a521eaea8c87ecde9a16dc5be4784f4ea7416d4d2cd497386ce60701984f471a1e2a346fc6b3bea04b9b0916803975a247079277083136e8f9f72e SHA512 9446c5e961272d196e51749376863befab7750a1b91990c40c1655676e9cc0c7f52435197fe8d44cab0dbc3e4deaa6fcede96c890305cb18ce68a5b091728306
-DIST Top-1.7.tar.gz 70721 BLAKE2B 90ddda99ab4dac209712494c28e15e90ffd2996151ab7df0a57fb8162bec09da6b28fd52b36672e081d10fa0b79d25bb2da2fd58d220573cea006d70c61229f0 SHA512 90d5f1042c07101c35bc1722c18667f551fa4d9034e70a4b7466ff25906899053a054f1227fed8d6d534d04fe9a1c2420585143cde44badfe98e08bf9a6225b4
-EBUILD top-1.7.ebuild 785 BLAKE2B 1c443146a5f76a3b4f942e065cca37abfb9b87a07ff30264e2bc0b1bac73d97ae1b22b8184960c5a3b487669be814b0552559747c2fcf4206dc2394209c0654a SHA512 9fb332ff68b4ee03ee6b041d50dcb9d8878e3228cebe5b4c5616360311f6cf71b5c6c98a63626b9b0bb6989b786d4d1734a3c5f7fa28acbe41f725d5ccd800cb
-MISC metadata.xml 663 BLAKE2B f38b48953db5fe32e1db91c329b762b9d091cceb906d76c2d28d27557b147d5e2c339b3bb9277a81f5d842d565514aed0ede21ab81aeb37887eeae3805d42cf6 SHA512 c54257e0c7514e8f7d3b316968fd40b629f3a4ee9e1c731ff89d9f4749998b937c10af27fb0cb475e283a7e4bb4bf0657437410556df07fb2656712267e08a20
diff --git a/dev-haskell/top/files/top-1.7-ghc-7.10.patch b/dev-haskell/top/files/top-1.7-ghc-7.10.patch
deleted file mode 100644
index 3acbda19e171..000000000000
--- a/dev-haskell/top/files/top-1.7-ghc-7.10.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff --git a/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs b/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-index 2cc5210..faf4c8c 100644
---- a/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-+++ b/src/Top/Implementation/TypeGraph/DefaultHeuristics.hs
-@@ -1,2 +1,3 @@
-+{-# LANGUAGE FlexibleContexts #-}
- -----------------------------------------------------------------------------
- -- | License : GPL
-diff --git a/src/Top/Monad/Select.hs b/src/Top/Monad/Select.hs
-index e5953cb..72276b4 100644
---- a/src/Top/Monad/Select.hs
-+++ b/src/Top/Monad/Select.hs
-@@ -16,4 +16,6 @@ module Top.Monad.Select
- import Top.Util.Embedding
- import Control.Monad.State
-+import Control.Monad
-+import Control.Applicative
-
- --------------------------------------------------------
-@@ -22,4 +24,11 @@ import Control.Monad.State
- newtype Select t m a = Select (m a)
-
-+instance Monad m => Functor (Select t m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (Select t m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (Select t m) where
- return a = Select (return a)
-@@ -43,4 +52,11 @@ select = Select
- data SelectFix (t :: (* -> *) -> *) (m :: * -> *) a = SelectFix (m a)
-
-+instance Monad m => Functor (SelectFix t m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (SelectFix t m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (SelectFix t m) where
- return a = SelectFix (return a)
-diff --git a/src/Top/Monad/StateFix.hs b/src/Top/Monad/StateFix.hs
-index d77919d..bd8fb76 100644
---- a/src/Top/Monad/StateFix.hs
-+++ b/src/Top/Monad/StateFix.hs
-@@ -16,4 +16,6 @@ import Control.Monad.State
- import Control.Monad.Identity
- import Control.Monad.Writer
-+import Control.Monad
-+import Control.Applicative
-
- type StateFix s = StateFixT s Identity
-@@ -21,4 +23,11 @@ type StateFix s = StateFixT s Identity
- data StateFixT s m a = Fix { unFix :: StateT (s (StateFixT s m)) m a }
-
-+instance Monad m => Functor (StateFixT s m) where
-+ fmap = liftM
-+
-+instance Monad m => Applicative (StateFixT s m) where
-+ pure = return
-+ (<*>) = ap -- defined in Control.Monad
-+
- instance Monad m => Monad (StateFixT s m) where
- return = Fix . return
diff --git a/dev-haskell/top/files/top-1.7-ghc84.patch b/dev-haskell/top/files/top-1.7-ghc84.patch
deleted file mode 100644
index 58ed02d3ff2a..000000000000
--- a/dev-haskell/top/files/top-1.7-ghc84.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/Top/Solver.hs
-+++ b/src/Top/Solver.hs
-@@ -26,2 +26,3 @@ import Top.Constraint.Information
- import Control.Monad.Writer
-+import qualified Data.Semigroup as S
-
-@@ -170,2 +171,5 @@ evalBasicMonad = runWriter . flip evalStateFixT empty
-
-+instance S.Semigroup LogEntries where
-+ (<>) (LogEntries f) (LogEntries g) = LogEntries (f . g)
-+
- instance Monoid LogEntries where
diff --git a/dev-haskell/top/metadata.xml b/dev-haskell/top/metadata.xml
deleted file mode 100644
index 1a045adcfaaf..000000000000
--- a/dev-haskell/top/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- At its most general, Top is a framework for constructing abstract interpretations
- which focuses on giving good feedback on why an abstract interpretation does not give
- any useful information. In a mathematical notation this is usually made explicit by
- returning the top element of a (complete) lattice. This is also one of the reasons
- for the name of the project.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-haskell/top/top-1.7.ebuild b/dev-haskell/top/top-1.7.ebuild
deleted file mode 100644
index d6b9761f6b81..000000000000
--- a/dev-haskell/top/top-1.7.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-MY_PN="Top"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Constraint solving framework employed by the Helium Compiler"
-HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
-SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-haskell/mtl:=[profile?]
- dev-haskell/parsec:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10.1.0
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-ghc-7.10.patch
- "${FILESDIR}"/${P}-ghc84.patch
-)